OpenMRS Admin UI Module location.gsp cross site scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
A vulnerability was found in OpenMRS Admin UI Module up to 1.5.x. It has been declared as problematic. This vulnerability affects unknown code of the file omod/src/main/webapp/pages/metadata/locations/location.gsp. The manipulation leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 1.6.0 is able to address this issue. The name of the patch is a7eefb5f69f6c50a3bffcb138bb8ea57cb41a9b6. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-216916.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2021-4291
- 2026-10-03 Alias added: GHSA-9fpp-2fqj-g2m7
References
More OpenMRS Admin Ui Module vulnerabilities
- TI-2021-03150 OpenMRS Admin UI Module Manage Privilege Page privilege.gsp cross site scripting CVSS 3.1MEDIUM 6.1
- TI-2020-18830 OpenMRS Admin UI Module Account Setup AccountPageController.java sendErrorMessage cross site scripting CVSS 3.1MEDIUM 6.1
Sources
- CVE-2021-4291 · CVE Program
- CVE-2021-4291 · NVD
- FIRST EPSS
- GHSA-9fpp-2fqj-g2m7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences