OpenMRS Admin UI Module Manage Privilege Page privilege.gsp cross site scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
A vulnerability was found in OpenMRS Admin UI Module up to 1.4.x. It has been rated as problematic. This issue affects some unknown processing of the file omod/src/main/webapp/pages/metadata/privileges/privilege.gsp of the component Manage Privilege Page. The manipulation leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 1.5.0 is able to address this issue. The name of the patch is 4f8565425b7c74128dec9ca46dfbb9a3c1c24911. It is recommended to upgrade the affected component. The identifier VDB-216917 was assigned to this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2021-4292
- 2026-10-03 Alias added: GHSA-wch7-2r9h-2rj5
References
More OpenMRS Admin Ui Module vulnerabilities
- TI-2021-03149 OpenMRS Admin UI Module location.gsp cross site scripting CVSS 3.1MEDIUM 6.1
- TI-2020-18830 OpenMRS Admin UI Module Account Setup AccountPageController.java sendErrorMessage cross site scripting CVSS 3.1MEDIUM 6.1
Sources
- CVE-2021-4292 · CVE Program
- CVE-2021-4292 · NVD
- FIRST EPSS
- GHSA-wch7-2r9h-2rj5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences