Custom Field Template <= 2.5.1 - Cross-Site Request Forgery Bypass
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-352.
Summary
The Custom Field Template plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 2.5.1. This is due to missing or incorrect nonce validation on the edit_meta_value() function. This makes it possible for unauthenticated attackers to edit meta field values via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Hiroaki Miyashita | Custom Field Template | before 2.5.2 | 2.5.2 | Patch available | CNA |
- Custom Field Template VendorHiroaki Miyashita Affected before 2.5.2 Fixed in 2.5.2 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wpgogo:custom_field_template:*:*:*:*:*:wordpress:*:* | up to 2.5.1 | Vulnerable | Hiroaki Miyashita |
- cpe:2.3:a:wpgogo:custom_field_template:*:*:*:*:*:wordpress:*:* Versions up to 2.5.1 Vulnerable ·Hiroaki Miyashita
Remediation
- Fix · CNA Custom Field Template (hiroaki-miyashita) Fixed in 2.5.2
Timeline
- 2026-10-02 Threatist record created from CVE-2020-36742
- 2026-10-03 Alias added: GHSA-j256-v92m-fqff
References
Advisory 8
- https://www.wordfence.com/threat-intel/vulnerabilities/id/3444c4b0-4619-482f-8313-d3006aa1e845?source=cve
- https://blog.nintechnet.com/25-wordpress-plugins-vulnerable-to-csrf-attacks/
- https://blog.nintechnet.com/more-wordpress-plugins-and-themes-vulnerable-to-csrf-attacks/
- https://blog.nintechnet.com/multiple-wordpress-plugins-fixed-csrf-vulnerabilities-part-3/
- https://blog.nintechnet.com/multiple-wordpress-plugins-fixed-csrf-vulnerabilities-part-2/
- https://blog.nintechnet.com/multiple-wordpress-plugins-fixed-csrf-vulnerabilities-part-1/
- https://blog.nintechnet.com/multiple-wordpress-plugins-fixed-csrf-vulnerabilities-part-5/
- https://blog.nintechnet.com/multiple-wordpress-plugins-fixed-csrf-vulnerabilities-part-4/
More Hiroaki Miyashita Custom Field Template vulnerabilities
- TI-2022-03960 Custom Field Template < 2.5.8 - Admin+ PHP Object Injection CVSS 3.1HIGH 7.2
- TI-2023-08870 WordPress Custom Field Template Plugin <= 2.5.8 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2023-19776 WordPress Custom Field Template Plugin <= 2.5.9 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
- TI-2024-29651 WordPress Custom Field Template plugin <= 2.6.5 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2024-00582 Custom Field Template <= 2.6.1 - Authenticated(Constibutor+) Stored Cross-Site Scripting via Custom Field Name CVSS 3.1MEDIUM 6.4
- TI-2023-06164 Custom Field Template <= 2.6.1 - Authenticated(Contributor+) Stored Cross-Site Scripting via shortcode CVSS 3.1MEDIUM 6.4
Sources
- CVE-2020-36742 · CVE Program
- CVE-2020-36742 · NVD
- FIRST EPSS
- GHSA-j256-v92m-fqff · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences