Read the docs
TI-2021-02661 Aliases CVE-2021-3728GHSA-xp5q-77mh-6hm2

Cross-Site Request Forgery (CSRF) in firefly-iii/firefly-iii

Priority LOW 29CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.

Summary

firefly-iii is vulnerable to Cross-Site Request Forgery (CSRF)

Why it matters now

EPSS 0.00501 43rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed grumpydictator/firefly-iii (Packagist): 5.6.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
firefly-iiifirefly-iii/firefly-iiiup to 5.5.13—No fix listedCNA
—grumpydictator/firefly-iii (Packagist)before 5.6.05.6.0Patch availableGHSA-xp5q-77mh-6hm2
  • firefly-iii/firefly-iii Vendorfirefly-iii Affected up to 5.5.13 Fixed in — No fix listed CNA
  • grumpydictator/firefly-iii (Packagist) Vendor— Affected before 5.6.0 Fixed in 5.6.0 Patch available GHSA-xp5q-77mh-6hm2

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:firefly-iii:firefly_iii:-:*:*:*:*:*:*:*not specified by NVDVulnerablefirefly-iii
  • cpe:2.3:a:firefly-iii:firefly_iii:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·firefly-iii

Remediation

  • Fix · GHSA-xp5q-77mh-6hm2 grumpydictator/firefly-iii (Packagist) Fixed in 5.6.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-3728
  2. 2026-10-03 Alias added: GHSA-xp5q-77mh-6hm2

References

  • TI-2023-01681 Improper Input Validation in firefly-iii/firefly-iii CVSS 3.1CRITICAL 9.8
  • TI-2023-01680 Insufficient Session Expiration in firefly-iii/firefly-iii CVSS 3.1CRITICAL 9.8
  • TI-2023-00283 Incorrect Authorization in firefly-iii/firefly-iii CVSS 3.1MEDIUM 6.5
  • TI-2019-10251 Firefly III before 4.7.17.1 is vulnerable to stored XSS due to lack of filtration of… CVSS 3.1MEDIUM 5.4
  • TI-2021-02811 Cross-Site Request Forgery (CSRF) in firefly-iii/firefly-iii CVSS 3.1HIGH 8.8
  • TI-2021-02777 Unrestricted Upload of File with Dangerous Type in firefly-iii/firefly-iii CVSS 3.1HIGH 8.8
See all 25 →

Sources