Read the docs
TI-2021-02804 Aliases CVE-2021-3882GHSA-q34c-v76q-8jx6

Sensitive Cookie in HTTPS Session Without 'Secure' Attribute in ledgersmb/ledgersmb

Priority LOW 32CWE-614Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
High
Impact type
Information disclosure
Confidentiality · integrity · availability
High · High · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-311.

Summary

LedgerSMB does not set the 'Secure' attribute on the session authorization cookie when the client uses HTTPS and the LedgerSMB server is behind a reverse proxy. By tricking a user to use an unencrypted connection (HTTP), an attacker may be able to obtain the authentication data by capturing network traffic. LedgerSMB 1.8 and newer switched from Basic authentication to using cookie authentication with encrypted cookies. Although an attacker can't access the information inside the cookie, nor the password of the user, possession of the cookie is enough to access the application as the user from which the cookie has been obtained. In order for the attacker to obtain the cookie, first of all the server must be configured to respond to unencrypted requests, the attacker must be suitably positioned to eavesdrop on the network traffic between the client and the server *and* the user must be tricked into using unencrypted HTTP traffic. Proper audit control and separation of duties limit Integrity impact of the attack vector. Users of LedgerSMB 1.8 are urged to upgrade to known-fixed versions. Users of LedgerSMB 1.7 or 1.9 are unaffected by this vulnerability and don't need to take action. As a workaround, users may configure their Apache or Nginx reverse proxy to add the Secure attribute at the network boundary instead of relying on LedgerSMB. For Apache, please refer to the 'Header always edit' configuration command in the mod_headers module. For Nginx, please refer to the 'proxy_cookie_flags' configuration command.

Why it matters now

EPSS 0.01134 66th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix No fix listed No fixed version in the sources yet

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
ledgersmbledgersmb/ledgersmb1.8.0 and later; up to 1.8.21—No fix listedCNA
  • ledgersmb/ledgersmb Vendorledgersmb Affected 1.8.0 and later; up to 1.8.21 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:ledgersmb:ledgersmb:*:*:*:*:*:*:*:*1.8.0 to before 1.8.22Vulnerableledgersmb
  • cpe:2.3:a:ledgersmb:ledgersmb:*:*:*:*:*:*:*:* Versions 1.8.0 to before 1.8.22 Vulnerable ·ledgersmb

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-3882
  2. 2026-10-03 Alias added: GHSA-q34c-v76q-8jx6

References

  • TI-2007-01278 Directory traversal vulnerability in SQL-Ledger, and LedgerSMB before 1.1.5, allows… CVSS 2.0HIGH 10.0
  • TI-2007-03785 Unspecified vulnerability in login.pl in LedgerSMB 1.2.0 through 1.2.6 allows remote… CVSS 2.0HIGH 10.0
  • TI-2021-02628 Cross-site Scripting (XSS) - DOM in ledgersmb/ledgersmb CVSS 3.1CRITICAL 9.6
  • TI-2018-06697 The PGObject::Util::DBAdmin module before 0.120.0 for Perl, as used in LedgerSMB through… CVSS 3.0CRITICAL 9.8
  • TI-2007-05160 Multiple SQL injection vulnerabilities in (a) LedgerSMB 1.0.0 through 1.2.7 and (b) DWS… CVSS 2.0HIGH 10.0
  • TI-2021-02629 Cross-site Scripting (XSS) - Reflected in ledgersmb/ledgersmb CVSS 3.1CRITICAL 9.6
See all 17 →

Sources