Read the docs
TI-2021-02847 Aliases CVE-2021-3943GHSA-8jhp-2gcr-qw96

Improper input validation in moodle

Priority MEDIUM 47CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.

Summary

A flaw was found in Moodle in versions 3.11 to 3.11.3, 3.10 to 3.10.7, 3.9 to 3.9.10 and earlier unsupported versions. A remote code execution risk when restoring backup files was identified.

Why it matters now

EPSS 0.02395 84th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.11.4, 3.10.8, 3.9.11

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—moodlemoodle 3.11.4, moodle 3.10.8 and moodle 3.9.11—No fix listedCNA
—moodle/moodle (Packagist)3.11 to before 3.11.43.11.4Patch availableGHSA-8jhp-2gcr-qw96
—moodle/moodle (Packagist)3.10 to before 3.10.83.10.8Patch availableGHSA-8jhp-2gcr-qw96
—moodle/moodle (Packagist)3.9 to before 3.9.113.9.11Patch availableGHSA-8jhp-2gcr-qw96
  • moodle Vendor— Affected moodle 3.11.4, moodle 3.10.8 and moodle 3.9.11 Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected 3.11 to before 3.11.4 Fixed in 3.11.4 Patch available GHSA-8jhp-2gcr-qw96
  • moodle/moodle (Packagist) Vendor— Affected 3.10 to before 3.10.8 Fixed in 3.10.8 Patch available GHSA-8jhp-2gcr-qw96
  • moodle/moodle (Packagist) Vendor— Affected 3.9 to before 3.9.11 Fixed in 3.9.11 Patch available GHSA-8jhp-2gcr-qw96

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*3.9.0 – 3.9.10; 3.10.0 – 3.10.7; 3.11.0 – 3.11.3VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 3.9.0 – 3.9.10; 3.10.0 – 3.10.7; 3.11.0 – 3.11.3 Vulnerable ·Moodle

Remediation

  • Fix · GHSA-8jhp-2gcr-qw96 moodle/moodle (Packagist) Fixed in 3.11.4 Advisory →
  • Fix · GHSA-8jhp-2gcr-qw96 moodle/moodle (Packagist) Fixed in 3.10.8 Advisory →
  • Fix · GHSA-8jhp-2gcr-qw96 moodle/moodle (Packagist) Fixed in 3.9.11 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-3943
  2. 2026-10-03 Alias added: GHSA-8jhp-2gcr-qw96

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources