Read the docs
TI-2021-03483 Aliases CVE-2021-20183GHSA-xhfx-rm8q-c3xv

Cross-site scripting in moodle

Priority LOW 26CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

It was found in Moodle before version 3.10.1 that some search inputs were vulnerable to reflected XSS due to insufficient escaping of search queries.

Why it matters now

EPSS 0.00826 57th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 4.0.0-beta

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—moodlemoodle 3.10.1—No fix listedCNA
—moodle/moodle (Packagist)3.10 to before 4.0.0-beta4.0.0-betaPatch availableGHSA-xhfx-rm8q-c3xv
  • moodle Vendor— Affected moodle 3.10.1 Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected 3.10 to before 4.0.0-beta Fixed in 4.0.0-beta Patch available GHSA-xhfx-rm8q-c3xv

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*before 3.10.1VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions before 3.10.1 Vulnerable ·Moodle

Remediation

  • Fix · GHSA-xhfx-rm8q-c3xv moodle/moodle (Packagist) Fixed in 4.0.0-beta Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-20183
  2. 2026-10-03 Alias added: GHSA-xhfx-rm8q-c3xv

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources