Read the docs
TI-2021-03485 Aliases CVE-2021-20185GHSA-c3j6-33r4-89q3

Uncontrolled resource consumption in moodle

Priority LOW 27CWE-400Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · Low
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-400.

Summary

It was found in Moodle before version 3.10.1, 3.9.4, 3.8.7 and 3.5.16 that messaging did not impose a character limit when sending messages, which could result in client-side (browser) denial of service for users receiving very large messages.

Why it matters now

EPSS 0.01394 72nd percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.5.16, 3.8.7, 3.9.4 +1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—moodlemoodle 3.10.1, moodle 3.9.4, moodle 3.8.7, moodle 3.5.16—No fix listedCNA
—moodle/moodle (Packagist)3.5 to before 3.5.163.5.16Patch availableGHSA-c3j6-33r4-89q3
—moodle/moodle (Packagist)3.8 to before 3.8.73.8.7Patch availableGHSA-c3j6-33r4-89q3
—moodle/moodle (Packagist)3.9 to before 3.9.43.9.4Patch availableGHSA-c3j6-33r4-89q3
—moodle/moodle (Packagist)3.10 to before 3.10.13.10.1Patch availableGHSA-c3j6-33r4-89q3
  • moodle Vendor— Affected moodle 3.10.1, moodle 3.9.4, moodle 3.8.7, moodle 3.5.16 Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected 3.5 to before 3.5.16 Fixed in 3.5.16 Patch available GHSA-c3j6-33r4-89q3
  • moodle/moodle (Packagist) Vendor— Affected 3.8 to before 3.8.7 Fixed in 3.8.7 Patch available GHSA-c3j6-33r4-89q3
  • moodle/moodle (Packagist) Vendor— Affected 3.9 to before 3.9.4 Fixed in 3.9.4 Patch available GHSA-c3j6-33r4-89q3
  • moodle/moodle (Packagist) Vendor— Affected 3.10 to before 3.10.1 Fixed in 3.10.1 Patch available GHSA-c3j6-33r4-89q3

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*3.5.0 to before 3.5.16; 3.8.0 to before 3.8.7; 3.9.0 to before 3.9.4VulnerableMoodle
cpe:2.3:a:moodle:moodle:3.10.0:*:*:*:*:*:*:*3.10.0VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 3.5.0 to before 3.5.16; 3.8.0 to before 3.8.7; 3.9.0 to before 3.9.4 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:3.10.0:*:*:*:*:*:*:* Versions 3.10.0 Vulnerable ·Moodle

Remediation

  • Fix · GHSA-c3j6-33r4-89q3 moodle/moodle (Packagist) Fixed in 3.5.16 Advisory →
  • Fix · GHSA-c3j6-33r4-89q3 moodle/moodle (Packagist) Fixed in 3.8.7 Advisory →
  • Fix · GHSA-c3j6-33r4-89q3 moodle/moodle (Packagist) Fixed in 3.9.4 Advisory →
  • Fix · GHSA-c3j6-33r4-89q3 moodle/moodle (Packagist) Fixed in 3.10.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-20185
  2. 2026-10-03 Alias added: GHSA-c3j6-33r4-89q3

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources