Cross-site scripting in moodle
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
The ID number user profile field required additional sanitizing to prevent a stored XSS risk in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | moodle | Fixed in 3.10.2, 3.9.5, 3.8.8, 3.5.17 | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 3.10 to before 3.10.2 | 3.10.2 | Patch available | GHSA-h7h6-fwpv-ggvx |
| — | moodle/moodle (Packagist) | 3.9 to before 3.9.5 | 3.9.5 | Patch available | GHSA-h7h6-fwpv-ggvx |
| — | moodle/moodle (Packagist) | 3.8 to before 3.8.8 | 3.8.8 | Patch available | GHSA-h7h6-fwpv-ggvx |
| — | moodle/moodle (Packagist) | 3.5 to before 3.5.17 | 3.5.17 | Patch available | GHSA-h7h6-fwpv-ggvx |
- moodle Vendor— Affected Fixed in 3.10.2, 3.9.5, 3.8.8, 3.5.17 Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 3.10 to before 3.10.2 Fixed in 3.10.2 Patch available GHSA-h7h6-fwpv-ggvx
- moodle/moodle (Packagist) Vendor— Affected 3.9 to before 3.9.5 Fixed in 3.9.5 Patch available GHSA-h7h6-fwpv-ggvx
- moodle/moodle (Packagist) Vendor— Affected 3.8 to before 3.8.8 Fixed in 3.8.8 Patch available GHSA-h7h6-fwpv-ggvx
- moodle/moodle (Packagist) Vendor— Affected 3.5 to before 3.5.17 Fixed in 3.5.17 Patch available GHSA-h7h6-fwpv-ggvx
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | 3.5.0 to before 3.5.17; 3.8.0 to before 3.8.8; 3.9.0 to before 3.9.5; 3.10.0 to before 3.10.2 | Vulnerable | Moodle |
| cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:* | 32 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:* | 34 | Vulnerable | Fedoraproject |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 3.5.0 to before 3.5.17; 3.8.0 to before 3.8.8; 3.9.0 to before 3.9.5; 3.10.0 to before 3.10.2 Vulnerable ·Moodle
- cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:* Versions 32 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:* Versions 34 Vulnerable ·Fedoraproject
Remediation
- Fix · GHSA-h7h6-fwpv-ggvx moodle/moodle (Packagist) Fixed in 3.10.2 Advisory →
- Fix · GHSA-h7h6-fwpv-ggvx moodle/moodle (Packagist) Fixed in 3.9.5 Advisory →
- Fix · GHSA-h7h6-fwpv-ggvx moodle/moodle (Packagist) Fixed in 3.8.8 Advisory →
- Fix · GHSA-h7h6-fwpv-ggvx moodle/moodle (Packagist) Fixed in 3.5.17 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
moodle — FEDORA-2021-1c27e89d49
5 records Highest priority Priority LOW 5 LOW
Other records, highest priority first
- TI-2021-03573 Incorrect authorization in moodlePriority LOW 27
- TI-2021-03572 Information disclosure in moodlePriority LOW 27
- TI-2021-03571 Cross-site scripting in moodlePriority LOW 27
- Advisory ·
moodle — FEDORA-2021-50f63a0161
5 records Highest priority Priority LOW 5 LOW
Other records, highest priority first
- TI-2021-03573 Incorrect authorization in moodlePriority LOW 27
- TI-2021-03572 Information disclosure in moodlePriority LOW 27
- TI-2021-03571 Cross-site scripting in moodlePriority LOW 27
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2021-20279
- 2026-10-03 Alias added: GHSA-h7h6-fwpv-ggvx
References
Advisory 4
Sources
- CVE-2021-20279 · CVE Program
- CVE-2021-20279 · NVD
- FIRST EPSS
- GHSA-h7h6-fwpv-ggvx · GitHub Advisory Database · CC BY 4.0
- CVE-2021-20279 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences