Cross-site scripting in moodle
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Text-based feedback answers required additional sanitizing to prevent stored XSS and blind SSRF risks in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | moodle | Fixed in 3.10.2, 3.9.5, 3.8.8, 3.5.17 | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 3.10 to before 3.10.2 | 3.10.2 | Patch available | GHSA-x2jp-hh65-4xvf |
| — | moodle/moodle (Packagist) | 3.9 to before 3.9.5 | 3.9.5 | Patch available | GHSA-x2jp-hh65-4xvf |
| — | moodle/moodle (Packagist) | 3.8 to before 3.8.8 | 3.8.8 | Patch available | GHSA-x2jp-hh65-4xvf |
| — | moodle/moodle (Packagist) | 3.5 to before 3.5.17 | 3.5.17 | Patch available | GHSA-x2jp-hh65-4xvf |
- moodle Vendor— Affected Fixed in 3.10.2, 3.9.5, 3.8.8, 3.5.17 Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 3.10 to before 3.10.2 Fixed in 3.10.2 Patch available GHSA-x2jp-hh65-4xvf
- moodle/moodle (Packagist) Vendor— Affected 3.9 to before 3.9.5 Fixed in 3.9.5 Patch available GHSA-x2jp-hh65-4xvf
- moodle/moodle (Packagist) Vendor— Affected 3.8 to before 3.8.8 Fixed in 3.8.8 Patch available GHSA-x2jp-hh65-4xvf
- moodle/moodle (Packagist) Vendor— Affected 3.5 to before 3.5.17 Fixed in 3.5.17 Patch available GHSA-x2jp-hh65-4xvf
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | 3.5.0 to before 3.5.17; 3.8.0 to before 3.8.8; 3.9.0 to before 3.9.5; 3.10.0 to before 3.10.2 | Vulnerable | Moodle |
| cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:* | 32 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:* | 33 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:* | 34 | Vulnerable | Fedoraproject |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 3.5.0 to before 3.5.17; 3.8.0 to before 3.8.8; 3.9.0 to before 3.9.5; 3.10.0 to before 3.10.2 Vulnerable ·Moodle
- cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:* Versions 32 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:* Versions 33 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:* Versions 34 Vulnerable ·Fedoraproject
Remediation
- Fix · GHSA-x2jp-hh65-4xvf moodle/moodle (Packagist) Fixed in 3.10.2 Advisory →
- Fix · GHSA-x2jp-hh65-4xvf moodle/moodle (Packagist) Fixed in 3.9.5 Advisory →
- Fix · GHSA-x2jp-hh65-4xvf moodle/moodle (Packagist) Fixed in 3.8.8 Advisory →
- Fix · GHSA-x2jp-hh65-4xvf moodle/moodle (Packagist) Fixed in 3.5.17 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
moodle — FEDORA-2021-1c27e89d49
5 records Highest priority Priority LOW 5 LOW
Other records, highest priority first
- TI-2021-03573 Incorrect authorization in moodlePriority LOW 27
- TI-2021-03572 Information disclosure in moodlePriority LOW 27
- TI-2021-03570 Cross-site scripting in moodlePriority LOW 26
- Advisory ·
moodle — FEDORA-2021-50f63a0161
5 records Highest priority Priority LOW 5 LOW
Other records, highest priority first
- TI-2021-03573 Incorrect authorization in moodlePriority LOW 27
- TI-2021-03572 Information disclosure in moodlePriority LOW 27
- TI-2021-03570 Cross-site scripting in moodlePriority LOW 26
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2021-20280
- 2026-10-03 Alias added: GHSA-x2jp-hh65-4xvf
References
Advisory 5
Other 5
- https://github.com/moodle/moodle/commit/a303eb9e9e387f95ea2a80cb1ce6c0b132ec1cc4
- https://github.com/moodle/moodle
- https://lists.fedoraproject.org/archives/list/[email protected]/message/AFSNJ7XHVTC52RSRX2GBQFF3VEEAY2MS
- https://lists.fedoraproject.org/archives/list/[email protected]/message/FGOMHMYM3WICJ6D6U22Z6LPJGT5A6MZM
- https://lists.fedoraproject.org/archives/list/[email protected]/message/UFH5DDMU5TZ3JT4Q52WMRAHACA5MHIMT
Sources
- CVE-2021-20280 · CVE Program
- CVE-2021-20280 · NVD
- FIRST EPSS
- GHSA-x2jp-hh65-4xvf · GitHub Advisory Database · CC BY 4.0
- CVE-2021-20280 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences