Read the docs
TI-2021-03574 Aliases CVE-2021-20283GHSA-2m72-m5cw-3g9h

Incorrect authorization in moodle

Priority LOW 22CWE-863Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
Low · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-863.

Summary

The web service responsible for fetching other users' enrolled courses did not validate that the requesting user had permission to view that information in each course in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.

Why it matters now

EPSS 0.0111 66th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.10.2, 3.9.5, 3.8.8 +1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—moodleFixed in 3.10.2, 3.9.5, 3.8.8, 3.5.17—No fix listedCNA
—moodle/moodle (Packagist)3.10.0 to before 3.10.23.10.2Patch availableGHSA-2m72-m5cw-3g9h
—moodle/moodle (Packagist)3.9.0 to before 3.9.53.9.5Patch availableGHSA-2m72-m5cw-3g9h
—moodle/moodle (Packagist)3.8.0 to before 3.8.83.8.8Patch availableGHSA-2m72-m5cw-3g9h
—moodle/moodle (Packagist)before 3.5.173.5.17Patch availableGHSA-2m72-m5cw-3g9h
  • moodle Vendor— Affected Fixed in 3.10.2, 3.9.5, 3.8.8, 3.5.17 Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected 3.10.0 to before 3.10.2 Fixed in 3.10.2 Patch available GHSA-2m72-m5cw-3g9h
  • moodle/moodle (Packagist) Vendor— Affected 3.9.0 to before 3.9.5 Fixed in 3.9.5 Patch available GHSA-2m72-m5cw-3g9h
  • moodle/moodle (Packagist) Vendor— Affected 3.8.0 to before 3.8.8 Fixed in 3.8.8 Patch available GHSA-2m72-m5cw-3g9h
  • moodle/moodle (Packagist) Vendor— Affected before 3.5.17 Fixed in 3.5.17 Patch available GHSA-2m72-m5cw-3g9h

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*3.5.0 to before 3.5.17; 3.8.0 to before 3.8.8; 3.9.0 to before 3.9.5; 3.10.0 to before 3.10.2VulnerableMoodle
cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:*32VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:*34VulnerableFedoraproject
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 3.5.0 to before 3.5.17; 3.8.0 to before 3.8.8; 3.9.0 to before 3.9.5; 3.10.0 to before 3.10.2 Vulnerable ·Moodle
  • cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:* Versions 32 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:* Versions 34 Vulnerable ·Fedoraproject

Remediation

  • Fix · GHSA-2m72-m5cw-3g9h moodle/moodle (Packagist) Fixed in 3.10.2 Advisory →
  • Fix · GHSA-2m72-m5cw-3g9h moodle/moodle (Packagist) Fixed in 3.9.5 Advisory →
  • Fix · GHSA-2m72-m5cw-3g9h moodle/moodle (Packagist) Fixed in 3.8.8 Advisory →
  • Fix · GHSA-2m72-m5cw-3g9h moodle/moodle (Packagist) Fixed in 3.5.17 Advisory →

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-20283
  2. 2026-10-03 Alias added: GHSA-2m72-m5cw-3g9h

References

Sources