Cross-site scripting in Dell Integrated Dell Remote Access Controller
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Dell EMC iDRAC9 versions prior to 4.40.00.00 contain a DOM-based cross-site scripting vulnerability. A remote unauthenticated attacker could potentially exploit this vulnerability by tricking a victim application user to supply malicious HTML or JavaScript code to DOM environment in the browser. The malicious code is then executed by the web browser in the context of the vulnerable web application.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
Remediation
- Fix · CNA Integrated Dell Remote Access Controller (iDRAC) (Dell) Fixed in 4.40.00.00
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Dell Integrated Dell Remote Access Controller (iDRAC) 4.40.00.00
5 records Highest priority Priority LOW 5 LOW
Other records, highest priority first
- TI-2021-04625 Stack-based buffer overflow in Dell Integrated Dell Remote Access ControllerPriority LOW 38
- TI-2021-04624 Time-of-check time-of-use race condition in Dell Integrated Dell Remote Access ControllerPriority LOW 32
- TI-2021-04628 Cross-site scripting in Dell Integrated Dell Remote Access ControllerPriority LOW 23
Timeline
- 2026-10-02 Threatist record created from CVE-2021-21541
- 2026-10-03 Alias added: GHSA-rmm3-386m-h9hc
References
More Dell Idrac9 Firmware vulnerabilities
- TI-2020-04396 Stack-based buffer overflow in Dell Integrated Dell Remote Access Controller CVSS 3.1CRITICAL 9.8
- TI-2019-02726 Buffer overflow in Dell EMC iDRAC CVSS 3.1CRITICAL 9.8
- TI-2019-02728 WS-MAN Authentication Bypass Vulnerability CVSS 3.0CRITICAL 9.8
- TI-2019-02727 Web Interface Authentication Bypass Vulnerability CVSS 3.0CRITICAL 9.8
- TI-2021-04623 Improper authentication in Dell Integrated Dell Remote Access Controller CVSS 3.1CRITICAL 10.0
- TI-2018-01149 iDRAC7/iDRAC8/iDrac9 contains a command injection vulnerability in the SNMP agent. CVSS 3.0HIGH 8.8
Sources
- CVE-2021-21541 · CVE Program
- CVE-2021-21541 · NVD
- FIRST EPSS
- GHSA-rmm3-386m-h9hc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences