Read the docs
TI-2021-04644 Aliases CVE-2021-21559GHSA-jqfx-r8vc-qw5m

Improper certificate validation in Dell NetWorker

Priority LOW 30CWE-295Published · Updated

Key facts

Attack vector
Adjacent network
Privileges required
None
User interaction
Required
Attack complexity
High
Impact type
Spoofing
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-295.

Summary

Dell EMC NetWorker, versions 18.x, 19.1.x, 19.2.x 19.3.x, 19.4, and 19.4.0.1 contain an Improper Certificate Validation vulnerability in the client (NetWorker Management Console) components which uses SSL encrypted connection in order to communicate with the application server. An unauthenticated attacker in the same network collision domain as the NetWorker Management Console client could potentially exploit this vulnerability to perform man-in-the-middle attacks to intercept and tamper the traffic between the client and the application server.

Why it matters now

EPSS 0.00166 5th percentileScored 2026-11-07
Fix Fixed NetWorker (Dell): 19.4.0.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
DellNetWorkerbefore 19.4.0.219.4.0.2Patch availableCNA
  • NetWorker VendorDell Affected before 19.4.0.2 Fixed in 19.4.0.2 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:dell:emc_networker:*:*:*:*:*:*:*:*18.1.0.1 to before 19.4.0.2VulnerableDell
  • cpe:2.3:a:dell:emc_networker:*:*:*:*:*:*:*:* Versions 18.1.0.1 to before 19.4.0.2 Vulnerable ·Dell

Remediation

  • Fix · CNA NetWorker (Dell) Fixed in 19.4.0.2

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    Dell NetWorker 19.4.0.2

    2 records Highest priority Priority LOW 2 LOW

    Other records, highest priority first

    • TI-2021-04643 Sensitive information in log files in Dell NetWorkerPriority LOW 35

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-21559
  2. 2026-10-03 Alias added: GHSA-jqfx-r8vc-qw5m

References

  • TI-2017-05620 EMC Networker Remote Code Execution Vulnerability CVSS 3.0CRITICAL 9.8
  • TI-2023-10194 Code injection in Dell NetWorker, NVE CVSS 3.1CRITICAL 9.8
  • TI-2018-01129 Memory corruption in Dell EMC NetWorker CVSS 3.0HIGH 7.5
  • TI-2018-07836 Cleartext transmission of sensitive information in Dell EMC Networker CVSS 3.0HIGH 8.8
  • TI-2021-04643 Sensitive information in log files in Dell NetWorker CVSS 3.1HIGH 8.2
  • TI-2023-10847 Information disclosure in Dell NetWorker, NVE CVSS 3.1HIGH 7.5
See all 17 →

Sources