JetWidgets For Elementor < 1.0.9 - Contributor+ Stored XSS
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The “JetWidgets For Elementor” WordPress Plugin before 1.0.9 has several widgets that are vulnerable to stored Cross-Site Scripting (XSS) by lower-privileged users such as contributors, all via a similar method.
Why it matters now
EPSS 0.0059 48th percentileScored 2026-11-07
Fix Fixed JetWidgets For Elementor (Unknown): 1.0.9
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | JetWidgets For Elementor | 1.0.9 to before 1.0.9 | 1.0.9 | Patch available | CNA |
- JetWidgets For Elementor VendorUnknown Affected 1.0.9 to before 1.0.9 Fixed in 1.0.9 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:crocoblock:jetwidgets_for_elementor:*:*:*:*:*:wordpress:*:* | before 1.0.9 | Vulnerable | Crocoblock |
- cpe:2.3:a:crocoblock:jetwidgets_for_elementor:*:*:*:*:*:wordpress:*:* Versions before 1.0.9 Vulnerable ·Crocoblock
Remediation
- Fix · CNA JetWidgets For Elementor (Unknown) Fixed in 1.0.9
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24268
- 2026-10-03 Alias added: GHSA-cvxv-m3wh-fqjf
References
More Crocoblock Jetwidgets For Elementor vulnerabilities
- TI-2023-00032 JetWidgets For Elementor < 1.0.14 - Contributor+ Stored XSS via Shortcode CVSS 3.1MEDIUM 5.4
- TI-2024-01988 JetWidgets For Elementor <= 1.0.15 - Authenticated (Contributor+) Stored Cross-Site Scripting via Animated Box Widget CVSS 3.1MEDIUM 6.4
- TI-2023-00082 JetWidgets for Elementor <= 1.0.12 - Cross-Site Request Forgery to Settings Update CVSS 3.1MEDIUM 6.5
- TI-2024-09564 JetWidgets For Elementor <= 1.0.18 - Authenticated (Author+) Stored Cross-Site Scripting via SVG File Upload CVSS 3.1MEDIUM 6.4
- TI-2024-04305 Cross-site scripting in jetmonsters JetWidgets For Elementor CVSS 3.1MEDIUM 6.4
- TI-2024-02332 JetWidgets For Elementor <= 1.0.16 - Authenticated(Contributor+) Stored Cross-Site Scripting via Widget Button URL CVSS 3.1MEDIUM 6.4
Sources
- CVE-2021-24268 · CVE Program
- CVE-2021-24268 · NVD
- FIRST EPSS
- GHSA-cvxv-m3wh-fqjf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences