JetWidgets For Elementor < 1.0.14 - Contributor+ Stored XSS via Shortcode
Priority MEDIUM 58Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The JetWidgets For Elementor WordPress plugin before 1.0.14 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00477 41st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed JetWidgets For Elementor (Unknown): 1.0.14
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | JetWidgets For Elementor | before 1.0.14 | 1.0.14 | Patch available | CNA |
- JetWidgets For Elementor VendorUnknown Affected before 1.0.14 Fixed in 1.0.14 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:crocoblock:jetwidgets_for_elementor:*:*:*:*:*:wordpress:*:* | up to 1.0.13 | Vulnerable | Crocoblock |
- cpe:2.3:a:crocoblock:jetwidgets_for_elementor:*:*:*:*:*:wordpress:*:* Versions up to 1.0.13 Vulnerable ·Crocoblock
Remediation
- Fix · CNA JetWidgets For Elementor (Unknown) Fixed in 1.0.14
Timeline
- 2026-10-02 Threatist record created from CVE-2023-0034
- 2026-10-03 Alias added: GHSA-8cwg-pj8f-8j23
References
More Crocoblock Jetwidgets For Elementor vulnerabilities
- TI-2024-01988 JetWidgets For Elementor <= 1.0.15 - Authenticated (Contributor+) Stored Cross-Site Scripting via Animated Box Widget CVSS 3.1MEDIUM 6.4
- TI-2023-00082 JetWidgets for Elementor <= 1.0.12 - Cross-Site Request Forgery to Settings Update CVSS 3.1MEDIUM 6.5
- TI-2024-09564 JetWidgets For Elementor <= 1.0.18 - Authenticated (Author+) Stored Cross-Site Scripting via SVG File Upload CVSS 3.1MEDIUM 6.4
- TI-2024-04305 Cross-site scripting in jetmonsters JetWidgets For Elementor CVSS 3.1MEDIUM 6.4
- TI-2024-02332 JetWidgets For Elementor <= 1.0.16 - Authenticated(Contributor+) Stored Cross-Site Scripting via Widget Button URL CVSS 3.1MEDIUM 6.4
- TI-2021-06560 JetWidgets For Elementor < 1.0.9 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
Sources
- CVE-2023-0034 · CVE Program
- CVE-2023-0034 · NVD
- FIRST EPSS
- GHSA-8cwg-pj8f-8j23 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences