PickPlugins Product Slider for WooCommerce < 1.13.22 - Reflected Cross-Site Scripting (XSS)
Priority MEDIUM 40CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The slider import search feature of the PickPlugins Product Slider for WooCommerce WordPress plugin before 1.13.22 did not properly sanitised the keyword GET parameter, leading to reflected Cross-Site Scripting issue
Why it matters now
EPSS 0.10587 95th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed PickPlugins Product Slider for WooCommerce (PickPlugins): 1.13.22
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| PickPlugins | PickPlugins Product Slider for WooCommerce | 1.13.22 to before 1.13.22 | 1.13.22 | Patch available | CNA |
- PickPlugins Product Slider for WooCommerce VendorPickPlugins Affected 1.13.22 to before 1.13.22 Fixed in 1.13.22 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pickplugins:product_slider_for_woocommerce:*:*:*:*:*:wordpress:*:* | before 1.13.22 | Vulnerable | PickPlugins |
- cpe:2.3:a:pickplugins:product_slider_for_woocommerce:*:*:*:*:*:wordpress:*:* Versions before 1.13.22 Vulnerable ·PickPlugins
Remediation
- Fix · CNA PickPlugins Product Slider for WooCommerce (PickPlugins) Fixed in 1.13.22
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24300
- 2026-10-03 Alias added: GHSA-72xr-97qw-3wch
References
More PickPlugins Product Slider For Woocommerce vulnerabilities
- TI-2023-00160 PickPlugins Product Slider for WooCommerce < 1.13.42 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2024-30502 Cross-site scripting in PickPlugins Product Slider for WooCommerce CVSS 3.1HIGH 7.1
Sources
- CVE-2021-24300 · CVE Program
- CVE-2021-24300 · NVD
- FIRST EPSS
- GHSA-72xr-97qw-3wch · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences