PickPlugins Product Slider for WooCommerce < 1.13.42 - Contributor+ Stored XSS
Priority MEDIUM 58Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Product Slider for WooCommerce by PickPlugins WordPress plugin before 1.13.42 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00477 41st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Product Slider for WooCommerce by PickPlugins (Unknown): 1.13.42
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Product Slider for WooCommerce by PickPlugins | before 1.13.42 | 1.13.42 | Patch available | CNA |
- Product Slider for WooCommerce by PickPlugins VendorUnknown Affected before 1.13.42 Fixed in 1.13.42 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pickplugins:product_slider_for_woocommerce:*:*:*:*:*:wordpress:*:* | before 1.13.42 | Vulnerable | PickPlugins |
- cpe:2.3:a:pickplugins:product_slider_for_woocommerce:*:*:*:*:*:wordpress:*:* Versions before 1.13.42 Vulnerable ·PickPlugins
Remediation
- Fix · CNA Product Slider for WooCommerce by PickPlugins (Unknown) Fixed in 1.13.42
Timeline
- 2026-10-02 Threatist record created from CVE-2023-0166
- 2026-10-03 Alias added: GHSA-xqq2-vhw7-qwjw
References
More PickPlugins Product Slider For Woocommerce vulnerabilities
- TI-2021-06592 PickPlugins Product Slider for WooCommerce < 1.13.22 - Reflected Cross-Site Scripting (XSS) CVSS 3.1MEDIUM 6.1
- TI-2024-30502 Cross-site scripting in PickPlugins Product Slider for WooCommerce CVSS 3.1HIGH 7.1
Sources
- CVE-2023-0166 · CVE Program
- CVE-2023-0166 · NVD
- FIRST EPSS
- GHSA-xqq2-vhw7-qwjw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences