WP Super Cache < 1.7.3 - Authenticated Stored Cross-Site Scripting (XSS)
Priority LOW 32CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The WP Super Cache WordPress plugin before 1.7.3 did not properly sanitise its wp_cache_location parameter in its settings, which could lead to a Stored Cross-Site Scripting issue.
Why it matters now
EPSS 0.04455 91st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed WP Super Cache (Unknown): 1.7.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WP Super Cache | 1.7.3 to before 1.7.3 | 1.7.3 | Patch available | CNA |
- WP Super Cache VendorUnknown Affected 1.7.3 to before 1.7.3 Fixed in 1.7.3 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:automattic:wp_super_cache:*:*:*:*:*:wordpress:*:* | before 1.7.3 | Vulnerable | Automattic |
- cpe:2.3:a:automattic:wp_super_cache:*:*:*:*:*:wordpress:*:* Versions before 1.7.3 Vulnerable ·Automattic
Remediation
- Fix · CNA WP Super Cache (Unknown) Fixed in 1.7.3
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24329
- 2026-10-03 Alias added: GHSA-w7f6-m3xq-9982
References
More Automattic Wp Super Cache vulnerabilities
- TI-2013-01782 WordPress W3 Total Cache Plugin 0.9.2.8 has a Remote PHP Code Execution Vulnerability CVSS 3.1CRITICAL 9.8
- TI-2013-01781 WordPress WP Super Cache Plugin 1.2 has Remote PHP Code Execution CVSS 3.1HIGH 8.8
- TI-2021-06501 WP Super Cache < 1.7.2 - Authenticated Remote Code Execution (RCE) CVSS 3.1HIGH 7.2
- TI-2021-06604 WP Super Cache < 1.7.3 - Authenticated Remote Code Execution CVSS 3.1HIGH 7.2
- TI-2013-01780 WordPress Super Cache Plugin 1.3 has XSS. CVSS 3.1MEDIUM 6.1
Sources
- CVE-2021-24329 · CVE Program
- CVE-2021-24329 · NVD
- FIRST EPSS
- GHSA-w7f6-m3xq-9982 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences