Read the docs
TI-2021-06783 Aliases CVE-2021-24496GHSA-9g3p-ghhv-vpv9

Community Event < 1.4.8 - Reflected Cross-Site Scripting (XSS)

Priority LOW 29CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The Community Events WordPress plugin before 1.4.8 does not sanitise, validate or escape its importrowscount and successimportcount GET parameters before outputting them back in an admin page, leading to a reflected Cross-Site Scripting issue which will be executed in the context of a logged in administrator

Why it matters now

EPSS 0.00827 57th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Community Events (Unknown): 1.4.8

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownCommunity Events1.4.8 to before 1.4.81.4.8Patch availableCNA
  • Community Events VendorUnknown Affected 1.4.8 to before 1.4.8 Fixed in 1.4.8 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:community_events_project:community_events:*:*:*:*:*:wordpress:*:*before 1.4.8VulnerableCommunity Events Project
  • cpe:2.3:a:community_events_project:community_events:*:*:*:*:*:wordpress:*:* Versions before 1.4.8 Vulnerable ·Community Events Project

Remediation

  • Fix · CNA Community Events (Unknown) Fixed in 1.4.8

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-24496
  2. 2026-10-03 Alias added: GHSA-9g3p-ghhv-vpv9

References

  • TI-2024-05818 Community Events < 1.5 - Event Deletion via CSRF CVSS 3.1MEDIUM 5.4
  • TI-2024-05817 Community Events < 1.5.1 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
  • TI-2015-02928 SQL injection vulnerability in WordPress Community Events plugin before 1.4. CVSS 3.0CRITICAL 9.8
  • TI-2022-22031 WordPress Community Events Plugin <= 1.4.8 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 4.8

Sources