Community Events < 1.5 - Event Deletion via CSRF
Priority MEDIUM 58CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-352.
Summary
The Community Events WordPress plugin before 1.5 does not have CSRF check in place when deleting events, which could allow attackers to make a logged in admin delete arbitrary events via a CSRF attack
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00272 19th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Community Events (Unknown): 1.5
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Community Events | before 1.5 | 1.5 | Patch available | CNA |
- Community Events VendorUnknown Affected before 1.5 Fixed in 1.5 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:community_events_project:community_events:*:*:*:*:*:wordpress:*:* | before 1.5 | Vulnerable | Community Events Project |
- cpe:2.3:a:community_events_project:community_events:*:*:*:*:*:wordpress:*:* Versions before 1.5 Vulnerable ·Community Events Project
Remediation
- Fix · CNA Community Events (Unknown) Fixed in 1.5
Timeline
- 2026-10-02 Threatist record created from CVE-2024-6271
- 2026-10-03 Alias added: GHSA-4mrc-7pp3-99pr
References
More Community Events Project Community Events vulnerabilities
- TI-2024-05817 Community Events < 1.5.1 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2015-02928 SQL injection vulnerability in WordPress Community Events plugin before 1.4. CVSS 3.0CRITICAL 9.8
- TI-2021-06783 Community Event < 1.4.8 - Reflected Cross-Site Scripting (XSS) CVSS 3.1MEDIUM 6.1
- TI-2022-22031 WordPress Community Events Plugin <= 1.4.8 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 4.8
Sources
- CVE-2024-6271 · CVE Program
- CVE-2024-6271 · NVD
- FIRST EPSS
- GHSA-4mrc-7pp3-99pr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences