Read the docs
TI-2024-05817 Aliases CVE-2024-6270GHSA-7vjh-vmrf-m55g

Community Events < 1.5.1 - Admin+ Stored XSS

Priority MEDIUM 55CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.

Summary

The Community Events WordPress plugin before 1.5.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00353 29th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Community Events (Unknown): 1.5.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownCommunity Eventsbefore 1.5.11.5.1Patch availableCNA
  • Community Events VendorUnknown Affected before 1.5.1 Fixed in 1.5.1 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:community_events_project:community_events:*:*:*:*:*:wordpress:*:*before 1.5.1VulnerableCommunity Events Project
  • cpe:2.3:a:community_events_project:community_events:*:*:*:*:*:wordpress:*:* Versions before 1.5.1 Vulnerable ·Community Events Project

Remediation

  • Fix · CNA Community Events (Unknown) Fixed in 1.5.1

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-6270
  2. 2026-10-03 Alias added: GHSA-7vjh-vmrf-m55g

References

  • TI-2024-05818 Community Events < 1.5 - Event Deletion via CSRF CVSS 3.1MEDIUM 5.4
  • TI-2015-02928 SQL injection vulnerability in WordPress Community Events plugin before 1.4. CVSS 3.0CRITICAL 9.8
  • TI-2021-06783 Community Event < 1.4.8 - Reflected Cross-Site Scripting (XSS) CVSS 3.1MEDIUM 6.1
  • TI-2022-22031 WordPress Community Events Plugin <= 1.4.8 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 4.8

Sources