WP Google Map < 1.7.7 - Authenticated Stored Cross-Site Scripting (XSS)
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The WP Google Map WordPress plugin before 1.7.7 did not sanitise or escape the Map Title before outputting them in the page, leading to a Stored Cross-Site Scripting issue by high privilege users, even when the unfiltered_html capability is disallowed
Why it matters now
EPSS 0.00668 52nd percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed Maps Plugin using Google Maps for WordPress – WP Google Map (Unknown): 1.7.7
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Maps Plugin using Google Maps for WordPress – WP Google Map | 1.7.7 to before 1.7.7 | 1.7.7 | Patch available | CNA |
- Maps Plugin using Google Maps for WordPress – WP Google Map VendorUnknown Affected 1.7.7 to before 1.7.7 Fixed in 1.7.7 Patch available CNA
Remediation
- Fix · CNA Maps Plugin using Google Maps for WordPress – WP Google Map (Unknown) Fixed in 1.7.7
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24502
- 2026-10-03 Alias added: GHSA-7hcc-mq7f-h4mv
References
More Weplugins Wp Maps vulnerabilities
- TI-2025-03078 WP Maps < 4.7.2 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2025-03077 WP Maps < 4.7.2 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2025-03076 WP Maps < 4.7.2 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2023-12741 WordPress WP Google Map Plugin Plugin <= 4.4.2 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2022-09190 WordPress WP Google Map plugin <= 4.2.3 - Cross-Site Request Forgery (CSRF) vulnerability CVSS 3.1HIGH 8.8
- TI-2015-07686 The wp-google-map-plugin plugin before 2.3.10 for WordPress has CSRF in the add/edit category feature. CVSS 3.1HIGH 8.8
Sources
- CVE-2021-24502 · CVE Program
- CVE-2021-24502 · NVD
- FIRST EPSS
- GHSA-7hcc-mq7f-h4mv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences