Read the docs
TI-2021-06847 Aliases CVE-2021-24562GHSA-h388-6737-2grv

LifterLMS < 4.21.2 - Access Other Student Grades/Answers via IDOR

Priority LOW 36CWE-639Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-639.

Summary

The LMS by LifterLMS – Online Course, Membership & Learning Management System Plugin for WordPress plugin before 4.21.2 was affected by an IDOR issue, allowing students to see other student answers and grades

Why it matters now

EPSS 0.01625 76th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed LMS by LifterLMS – Online Course, Membership & Learning Management System Plugin for WordPress (Unknown): 4.21.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownLMS by LifterLMS – Online Course, Membership & Learning Management System Plugin for WordPress4.21.2 to before 4.21.24.21.2Patch availableCNA
  • LMS by LifterLMS – Online Course, Membership & Learning Management System Plugin for WordPress VendorUnknown Affected 4.21.2 to before 4.21.2 Fixed in 4.21.2 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:lifterlms:lifterlms:*:*:*:*:*:wordpress:*:*before 4.21.2Vulnerablechrisbadgett
  • cpe:2.3:a:lifterlms:lifterlms:*:*:*:*:*:wordpress:*:* Versions before 4.21.2 Vulnerable ·chrisbadgett

Remediation

  • Fix · CNA LMS by LifterLMS – Online Course, Membership & Learning Management System Plugin for WordPress (Unknown) Fixed in 4.21.2

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-24562
  2. 2026-10-03 Alias added: GHSA-h388-6737-2grv

References

  • TI-2024-12660 LifterLMS – WP LMS for eLearning, Online Courses, & Quizzes < 8.0.1 - Reflected XSS CVSS 3.1MEDIUM 6.1
  • TI-2019-11948 An issue was discovered in the LifterLMS plugin through 3.34.5 for WordPress. CVSS 3.1CRITICAL 9.8
  • TI-2020-04909 LifterLMS Wordpress plugin version below 3.37.15 is vulnerable to arbitrary file write leading to remote code execution CVSS 3.1CRITICAL 9.8
  • TI-2025-32767 WordPress LifterLMS plugin <= 8.0.6 - SQL Injection Vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2024-04416 LifterLMS – WordPress LMS Plugin for eLearning <= 7.6.2 - Authenticated (Contributor+) SQL Injection via Shortcode CVSS 3.1HIGH 8.8
  • TI-2024-20735 WordPress LifterLMS plugin <= 7.5.0 - Cross Site Request Forgery (CSRF) vulnerability CVSS 3.1HIGH 8.8
See all 13 →

Sources