LifterLMS – WP LMS for eLearning, Online Courses, & Quizzes < 8.0.1 - Reflected XSS
Priority MEDIUM 60CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The LifterLMS WordPress plugin before 8.0.1 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00579 47th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed LifterLMS (Unknown): 8.0.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | LifterLMS | before 8.0.1 | 8.0.1 | Patch available | CNA |
- LifterLMS VendorUnknown Affected before 8.0.1 Fixed in 8.0.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:lifterlms:lifterlms:*:*:*:*:*:wordpress:*:* | before 8.0.1 | Vulnerable | chrisbadgett |
- cpe:2.3:a:lifterlms:lifterlms:*:*:*:*:*:wordpress:*:* Versions before 8.0.1 Vulnerable ·chrisbadgett
Remediation
- Fix · CNA LifterLMS (Unknown) Fixed in 8.0.1
Timeline
- 2026-10-02 Threatist record created from CVE-2024-13619
- 2026-10-03 Alias added: GHSA-v6jx-8472-465v
References
More chrisbadgett Lifterlms vulnerabilities
- TI-2019-11948 An issue was discovered in the LifterLMS plugin through 3.34.5 for WordPress. CVSS 3.1CRITICAL 9.8
- TI-2020-04909 LifterLMS Wordpress plugin version below 3.37.15 is vulnerable to arbitrary file write leading to remote code execution CVSS 3.1CRITICAL 9.8
- TI-2025-32767 WordPress LifterLMS plugin <= 8.0.6 - SQL Injection Vulnerability CVSS 3.1CRITICAL 9.8
- TI-2024-04416 LifterLMS – WordPress LMS Plugin for eLearning <= 7.6.2 - Authenticated (Contributor+) SQL Injection via Shortcode CVSS 3.1HIGH 8.8
- TI-2024-20735 WordPress LifterLMS plugin <= 7.5.0 - Cross Site Request Forgery (CSRF) vulnerability CVSS 3.1HIGH 8.8
- TI-2021-06847 LifterLMS < 4.21.2 - Access Other Student Grades/Answers via IDOR CVSS 3.1HIGH 7.5
Sources
- CVE-2024-13619 · CVE Program
- CVE-2024-13619 · NVD
- FIRST EPSS
- GHSA-v6jx-8472-465v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences