Bold Page Builder < 3.1.6 - PHP Object Injection
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-502.
Summary
The bt_bb_get_grid AJAX action of the Bold Page Builder WordPress plugin before 3.1.6 passes user input into the unserialize() function without any validation or sanitisation, which could lead to a PHP Object Injection. Even though the plugin did not contain a suitable gadget to fully exploit the issue, other installed plugins on the blog could allow such issue to be exploited and lead to RCE in some cases.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Bold Page Builder | 3.1.6 to before 3.1.6 | 3.1.6 | Patch available | CNA |
- Bold Page Builder VendorUnknown Affected 3.1.6 to before 3.1.6 Fixed in 3.1.6 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:bold-themes:bold_page_builder:*:*:*:*:*:wordpress:*:* | before 3.1.6 | Vulnerable | boldthemes |
- cpe:2.3:a:bold-themes:bold_page_builder:*:*:*:*:*:wordpress:*:* Versions before 3.1.6 Vulnerable ·boldthemes
Remediation
- Fix · CNA Bold Page Builder (Unknown) Fixed in 3.1.6
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24579
- 2026-10-03 Alias added: GHSA-7m4f-494f-vxhx
References
More boldthemes Bold Page Builder vulnerabilities
- TI-2019-11888 The bold-page-builder plugin before 2.3.2 for WordPress has no protection against modifying settings and importing data. CVSS 3.0HIGH 7.5
- TI-2024-33850 WordPress Bold Page Builder plugin <= 5.1.3 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
- TI-2024-35999 WordPress Bold Page Builder plugin <= 5.2.1 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2024-31709 WordPress Bold Page Builder plugin < 5.1.1 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2024-31616 WordPress Bold Page Builder plugin <= 5.1.1 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2024-20168 WordPress Bold Page Builder plugin <= 4.8.0 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
Sources
- CVE-2021-24579 · CVE Program
- CVE-2021-24579 · NVD
- FIRST EPSS
- GHSA-7m4f-494f-vxhx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences