Translate WordPress - Google Language Translator < 6.0.12 - Admin+ Stored Cross-Site Scripting
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Translate WordPress – Google Language Translator WordPress plugin before 6.0.12 does not sanitise and escape some of its settings before outputting it in various pages, allowing high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Why it matters now
EPSS 0.00676 52nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Translate WordPress – Google Language Translator (Unknown): 6.0.12
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Translate WordPress – Google Language Translator | 6.0.12 to before 6.0.12 | 6.0.12 | Patch available | CNA |
- Translate WordPress – Google Language Translator VendorUnknown Affected 6.0.12 to before 6.0.12 Fixed in 6.0.12 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gtranslate:google_language_translator:*:*:*:*:*:wordpress:*:* | before 6.0.12 | Vulnerable | Gtranslate |
- cpe:2.3:a:gtranslate:google_language_translator:*:*:*:*:*:wordpress:*:* Versions before 6.0.12 Vulnerable ·Gtranslate
Remediation
- Fix · CNA Translate WordPress – Google Language Translator (Unknown) Fixed in 6.0.12
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24594
- 2026-10-03 Alias added: GHSA-wgwv-6x26-xh66
References
More Gtranslate Google Language Translator vulnerabilities
- TI-2021-03308 Google Language Translator <= 6.0.9 - Reflected Cross-Site Scripting CVSS 3.1HIGH 7.1
- TI-2016-08908 The google-language-translator plugin before 5.0.06 for WordPress has XSS. CVSS 3.0MEDIUM 6.1
Sources
- CVE-2021-24594 · CVE Program
- CVE-2021-24594 · NVD
- FIRST EPSS
- GHSA-wgwv-6x26-xh66 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences