Email Encoder < 2.1.2 - Reflected Cross Site Scripting
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Email Encoder – Protect Email Addresses WordPress plugin before 2.1.2 has an endpoint that requires no authentication and will render a user supplied value in the HTML response without escaping or sanitizing the data.
Why it matters now
EPSS 0.00855 58th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Email Encoder – Protect Email Addresses (Unknown): 2.1.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Email Encoder – Protect Email Addresses | 2.1.2 to before 2.1.2 | 2.1.2 | Patch available | CNA |
- Email Encoder – Protect Email Addresses VendorUnknown Affected 2.1.2 to before 2.1.2 Fixed in 2.1.2 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wp-webhooks:email_encoder:*:*:*:*:*:wordpress:*:* | before 2.1.2 | Vulnerable | Wp-webhooks |
- cpe:2.3:a:wp-webhooks:email_encoder:*:*:*:*:*:wordpress:*:* Versions before 2.1.2 Vulnerable ·Wp-webhooks
Remediation
- Fix · CNA Email Encoder – Protect Email Addresses (Unknown) Fixed in 2.1.2
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24599
- 2026-10-03 Alias added: GHSA-vwmw-f3cr-593g
References
More Wp-webhooks Email Encoder vulnerabilities
- TI-2024-04170 Email Encoder < 2.2.2 - Admin+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2023-04243 Email Encoder <= 2.1.8 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode CVSS 3.1MEDIUM 6.4
Sources
- CVE-2021-24599 · CVE Program
- CVE-2021-24599 · NVD
- FIRST EPSS
- GHSA-vwmw-f3cr-593g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences