Read the docs
TI-2021-06932 Aliases CVE-2021-24649GHSA-f4mf-54pp-jfrw

WP User Frontend < 3.5.29 - Obscure Registration as Admin

Priority HIGH 82Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.

Summary

The WP User Frontend WordPress plugin before 3.5.29 uses a user supplied argument called urhidden in its registration form, which contains the role for the account to be created with, encrypted via wpuf_encryption(). This could allow an attacker having access to the AUTH_KEY and AUTH_SALT constant (via an arbitrary file access issue for example, or if the blog is using the default keys) to create an account with any role they want, such as admin

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00706 53rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed WP User Frontend (Unknown): 3.5.29

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownWP User Frontendbefore 3.5.293.5.29Patch availableCNA
  • WP User Frontend VendorUnknown Affected before 3.5.29 Fixed in 3.5.29 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:wedevs:wp_user_frontend:*:*:*:*:*:wordpress:*:*before 3.5.29VulnerableweDevs
  • cpe:2.3:a:wedevs:wp_user_frontend:*:*:*:*:*:wordpress:*:* Versions before 3.5.29 Vulnerable ·weDevs

Remediation

  • Fix · CNA WP User Frontend (Unknown) Fixed in 3.5.29

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-24649
  2. 2026-10-03 Alias added: GHSA-f4mf-54pp-jfrw

References

  • TI-2021-07354 WP User Frontend < 3.5.26 - SQL Injection to Reflected Cross-Site Scripting CVSS 3.1HIGH 8.8
  • TI-2024-25927 WordPress WP User Frontend plugin <= 4.0.7 - SQL Injection vulnerability CVSS 3.1HIGH 7.6

Sources