WP User Frontend < 3.5.26 - SQL Injection to Reflected Cross-Site Scripting
Priority MEDIUM 55CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-89.
Summary
The WP User Frontend WordPress plugin before 3.5.26 does not validate and escape the status parameter before using it in a SQL statement in the Subscribers dashboard, leading to an SQL injection. Due to the lack of sanitisation and escaping, this could also lead to Reflected Cross-Site Scripting
Why it matters now
EPSS 0.17255 97th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed WP User Frontend – Membership, Profile, Registration & Post Submission Plugin for WordPress (Unknown): 3.5.26
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WP User Frontend – Membership, Profile, Registration & Post Submission Plugin for WordPress | 3.5.26 to before 3.5.26 | 3.5.26 | Patch available | CNA |
- WP User Frontend – Membership, Profile, Registration & Post Submission Plugin for WordPress VendorUnknown Affected 3.5.26 to before 3.5.26 Fixed in 3.5.26 Patch available CNA
Remediation
- Fix · CNA WP User Frontend – Membership, Profile, Registration & Post Submission Plugin for WordPress (Unknown) Fixed in 3.5.26
Timeline
- 2026-10-02 Threatist record created from CVE-2021-25076
- 2026-10-03 Alias added: GHSA-gx4g-7h78-x658
References
More weDevs Wp User Frontend vulnerabilities
- TI-2021-06932 WP User Frontend < 3.5.29 - Obscure Registration as Admin CVSS 3.1CRITICAL 9.8
- TI-2024-25927 WordPress WP User Frontend plugin <= 4.0.7 - SQL Injection vulnerability CVSS 3.1HIGH 7.6
Sources
- CVE-2021-25076 · CVE Program
- CVE-2021-25076 · NVD
- FIRST EPSS
- GHSA-gx4g-7h78-x658 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences