Read the docs
TI-2021-06933 Aliases CVE-2021-24651GHSA-64xf-q24f-59cv

Poll Maker < 3.4.2 - Unauthenticated Time Based SQL Injection

Priority LOW 36CWE-203Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Information disclosure, SQL injection
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-203 and CWE-89.

Summary

The Poll Maker WordPress plugin before 3.4.2 allows unauthenticated users to perform SQL injection via the ays_finish_poll AJAX action. While the result is not disclosed in the response, it is possible to use a timing attack to exfiltrate data such as password hash.

Why it matters now

EPSS 0.0164 76th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Poll Maker (Unknown): 3.4.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownPoll Maker3.4.2 to before 3.4.23.4.2Patch availableCNA
  • Poll Maker VendorUnknown Affected 3.4.2 to before 3.4.2 Fixed in 3.4.2 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:ays-pro:poll_maker:*:*:*:*:*:wordpress:*:*before 3.4.2VulnerableAys Pro
  • cpe:2.3:a:ays-pro:poll_maker:*:*:*:*:*:wordpress:*:* Versions before 3.4.2 Vulnerable ·Ays Pro

Remediation

  • Fix · CNA Poll Maker (Unknown) Fixed in 3.4.2

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-24651
  2. 2026-10-03 Alias added: GHSA-64xf-q24f-59cv

References

  • TI-2024-12643 Poll Maker < 5.5.4 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
  • TI-2025-18294 WordPress Poll Maker plugin <= 5.5.0 - Broken Access Control vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2025-19842 WordPress Poll Maker <= 5.6.5 - SQL Injection vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2025-30042 WordPress Poll Maker plugin <= 5.7.7 - Race Condition Vulnerability CVSS 3.1HIGH 8.1
  • TI-2023-16880 WordPress Poll Maker Plugin <= 4.6.2 is vulnerable to Server Side Request Forgery (SSRF) CVSS 3.1HIGH 7.5
  • TI-2024-37264 WordPress Poll Maker plugin <= 5.5.6 - Broken Access Control vulnerability CVSS 3.1MEDIUM 6.5
See all 19 →

Sources