Podlove Podcast Publisher < 3.5.6 - Unauthenticated SQL Injection
Priority MEDIUM 54CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-89.
Summary
The Podlove Podcast Publisher WordPress plugin before 3.5.6 contains a 'Social & Donations' module (not activated by default), which adds the rest route '/services/contributor/(?P<id>[\d]+), takes an 'id' and 'category' parameters as arguments. Both parameters can be used for the SQLi.
Why it matters now
EPSS 0.08883 95th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Podlove Podcast Publisher (Unknown): 3.5.6
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Podlove Podcast Publisher | 3.5.6 to before 3.5.6 | 3.5.6 | Patch available | CNA |
- Podlove Podcast Publisher VendorUnknown Affected 3.5.6 to before 3.5.6 Fixed in 3.5.6 Patch available CNA
Remediation
- Fix · CNA Podlove Podcast Publisher (Unknown) Fixed in 3.5.6
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24666
- 2026-10-03 Alias added: GHSA-2c3j-j92w-h38q
References
More Podlove Podcast Publisher vulnerabilities
- TI-2024-19682 WordPress Podlove Podcast Publisher plugin <= 4.0.9 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
- TI-2024-12769 Podlove Podcast Publisher < 4.2.1 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2024-12768 Podlove Podcast Publisher < 4.1.24 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2016-08980 The podlove-podcasting-plugin-for-wordpress plugin before 2.3.16 for WordPress has SQL… CVSS 3.1CRITICAL 9.8
- TI-2024-29573 WordPress Podlove Podcast Publisher plugin <= 4.1.13 - CSRF to Remote Code Execution (RCE) vulnerability CVSS 3.1CRITICAL 9.6
- TI-2024-35064 WordPress Podlove Podcast Publisher plugin <= 4.1.15 - Admin+ Remote Code Execution (RCE) vulnerability CVSS 3.1CRITICAL 9.1
Sources
- CVE-2021-24666 · CVE Program
- CVE-2021-24666 · NVD
- FIRST EPSS
- GHSA-2c3j-j92w-h38q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences