Read the docs
TI-2024-12769 Aliases CVE-2024-13730GHSA-h2f3-9263-mhpx

Podlove Podcast Publisher < 4.2.1 - Admin+ Stored XSS

Priority MEDIUM 55CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.

Summary

The Podlove Podcast Publisher WordPress plugin before 4.2.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00326 25th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Podlove Podcast Publisher (Unknown): 4.2.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownPodlove Podcast Publisherbefore 4.2.14.2.1Patch availableCNA
  • Podlove Podcast Publisher VendorUnknown Affected before 4.2.1 Fixed in 4.2.1 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:podlove:podlove_podcast_publisher:*:*:*:*:*:wordpress:*:*before 4.2.1VulnerablePodlove
  • cpe:2.3:a:podlove:podlove_podcast_publisher:*:*:*:*:*:wordpress:*:* Versions before 4.2.1 Vulnerable ·Podlove

Remediation

  • Fix · CNA Podlove Podcast Publisher (Unknown) Fixed in 4.2.1

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-13730
  2. 2026-10-03 Alias added: GHSA-h2f3-9263-mhpx

References

  • TI-2024-19682 WordPress Podlove Podcast Publisher plugin <= 4.0.9 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
  • TI-2024-12768 Podlove Podcast Publisher < 4.1.24 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
  • TI-2021-06948 Podlove Podcast Publisher < 3.5.6 - Unauthenticated SQL Injection CVSS 3.1CRITICAL 9.8
  • TI-2016-08980 The podlove-podcasting-plugin-for-wordpress plugin before 2.3.16 for WordPress has SQL… CVSS 3.1CRITICAL 9.8
  • TI-2024-29573 WordPress Podlove Podcast Publisher plugin <= 4.1.13 - CSRF to Remote Code Execution (RCE) vulnerability CVSS 3.1CRITICAL 9.6
  • TI-2024-35064 WordPress Podlove Podcast Publisher plugin <= 4.1.15 - Admin+ Remote Code Execution (RCE) vulnerability CVSS 3.1CRITICAL 9.1
See all 19 →

Sources