Flat Preloader < 1.5.4 - CSRF to Stored Cross-Site Scripting
Priority LOW 25CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering, Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-352 and CWE-79.
Summary
The Flat Preloader WordPress plugin before 1.5.4 does not enforce nonce checks when saving its settings, as well as does not sanitise and escape them, which could allow attackers to a make logged in admin change them with a Cross-Site Scripting payload (triggered either in the frontend or backend depending on the payload)
Why it matters now
EPSS 0.00507 43rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Flat Preloader (Unknown): 1.5.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Flat Preloader | 1.5.4 to before 1.5.4 | 1.5.4 | Patch available | CNA |
- Flat Preloader VendorUnknown Affected 1.5.4 to before 1.5.4 Fixed in 1.5.4 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:flat_preloader_project:flat_preloader:*:*:*:*:*:wordpress:*:* | before 1.5.4 | Vulnerable | Flat Preloader Project |
- cpe:2.3:a:flat_preloader_project:flat_preloader:*:*:*:*:*:wordpress:*:* Versions before 1.5.4 Vulnerable ·Flat Preloader Project
Remediation
- Fix · CNA Flat Preloader (Unknown) Fixed in 1.5.4
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24685
- 2026-10-03 Alias added: GHSA-3mcq-mff7-29h7
References
More Flat Preloader Project Flat Preloader vulnerabilities
- TI-2021-07071 Flat Preloader < 1.5.5 - Admin+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 4.8
Sources
- CVE-2021-24685 · CVE Program
- CVE-2021-24685 · NVD
- FIRST EPSS
- GHSA-3mcq-mff7-29h7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences