Read the docs
TI-2021-07071 Aliases CVE-2021-24789GHSA-grw5-p86m-w8x6

Flat Preloader < 1.5.5 - Admin+ Stored Cross-Site Scripting

Priority LOW 23CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The Flat Preloader WordPress plugin before 1.5.5 does not escape some of its settings when outputting them in attribute in the frontend, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html is disallowed

Why it matters now

EPSS 0.00643 51st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Flat Preloader (Unknown): 1.5.5

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownFlat Preloader1.5.5 to before 1.5.51.5.5Patch availableCNA
  • Flat Preloader VendorUnknown Affected 1.5.5 to before 1.5.5 Fixed in 1.5.5 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:flat_preloader_project:flat_preloader:*:*:*:*:*:wordpress:*:*before 1.5.5VulnerableFlat Preloader Project
  • cpe:2.3:a:flat_preloader_project:flat_preloader:*:*:*:*:*:wordpress:*:* Versions before 1.5.5 Vulnerable ·Flat Preloader Project

Remediation

  • Fix · CNA Flat Preloader (Unknown) Fixed in 1.5.5

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-24789
  2. 2026-10-03 Alias added: GHSA-grw5-p86m-w8x6
  3. 2026-10-21 EPSS moved to the 50th–90th percentile

References

  • TI-2021-06967 Flat Preloader < 1.5.4 - CSRF to Stored Cross-Site Scripting CVSS 3.1MEDIUM 5.4

Sources