GeoDirectory < 2.1.1.3 - Authenticated Stored Cross-Site Scripting (XSS)
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The GeoDirectory Business Directory WordPress plugin before 2.1.1.3 was vulnerable to Authenticated Stored Cross-Site Scripting (XSS).
Why it matters now
EPSS 0.00882 59th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed Business Directory Plugin | GeoDirectory (Unknown): 2.1.1.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Business Directory Plugin | GeoDirectory | 2.1.1.3 to before 2.1.1.3 | 2.1.1.3 | Patch available | CNA |
- Business Directory Plugin | GeoDirectory VendorUnknown Affected 2.1.1.3 to before 2.1.1.3 Fixed in 2.1.1.3 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ayecode:geodirectory:*:*:*:*:*:wordpress:*:* | before 2.1.1.3 | Vulnerable | AyeCode Ltd |
- cpe:2.3:a:ayecode:geodirectory:*:*:*:*:*:wordpress:*:* Versions before 2.1.1.3 Vulnerable ·AyeCode Ltd
Remediation
- Fix · CNA Business Directory Plugin | GeoDirectory (Unknown) Fixed in 2.1.1.3
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24720
- 2026-10-03 Alias added: GHSA-75mg-7wpw-49q3
References
More AyeCode Ltd Geodirectory vulnerabilities
- TI-2024-28816 WordPress GeoDirectory plugin <= 2.3.61 - SQL Injection vulnerability CVSS 3.1HIGH 8.8
- TI-2022-04371 GeoDirectory < 2.2.22 - Contributor+ Stored XSS via Shortcode CVSS 3.1MEDIUM 5.4
- TI-2025-05608 GeoDirectory < 2.8.120 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.9
- TI-2024-29570 WordPress GeoDirectory plugin <= 2.3.70 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
- TI-2023-27750 WordPress GeoDirectory Plugin <= 2.3.28 is vulnerable to SQL Injection CVSS 3.1HIGH 7.6
- TI-2024-37229 WordPress GeoDirectory plugin <= 2.3.84 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
Sources
- CVE-2021-24720 · CVE Program
- CVE-2021-24720 · NVD
- FIRST EPSS
- GHSA-75mg-7wpw-49q3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences