Read the docs
TI-2021-07037 Aliases CVE-2021-24755GHSA-9q3v-827r-c9mw

myCred < 2.3 - Subscriber+ SQL Injection

Priority MEDIUM 41CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
SQL injection
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-89.

Summary

The myCred WordPress plugin before 2.3 does not validate or escape the fields parameter before using it in a SQL statement, leading to an SQL injection exploitable by any authenticated user

Why it matters now

EPSS 0.01361 71st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed myCred – Points, Rewards, Gamification, Ranks, Badges & Loyalty Plugin (Unknown): 2.3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownmyCred – Points, Rewards, Gamification, Ranks, Badges & Loyalty Plugin2.3 to before 2.32.3Patch availableCNA
  • myCred – Points, Rewards, Gamification, Ranks, Badges & Loyalty Plugin VendorUnknown Affected 2.3 to before 2.3 Fixed in 2.3 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:wpexperts:mycred:*:*:*:*:*:wordpress:*:*before 2.3VulnerableWPExperts
  • cpe:2.3:a:wpexperts:mycred:*:*:*:*:*:wordpress:*:* Versions before 2.3 Vulnerable ·WPExperts

Remediation

  • Fix · CNA myCred – Points, Rewards, Gamification, Ranks, Badges & Loyalty Plugin (Unknown) Fixed in 2.3

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-24755
  2. 2026-10-03 Alias added: GHSA-9q3v-827r-c9mw

References

  • TI-2023-17566 WordPress myCred Plugin <= 2.5 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
  • TI-2024-28867 WordPress myCred plugin <= 2.7.2 - Sensitive Data Exposure vulnerability CVSS 3.1MEDIUM 5.3
  • TI-2023-25961 WordPress myCred Plugin <= 2.6.1 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
  • TI-2022-00219 Mycred < 2.4.4.1 - Subscriber+ User E-mail Addresses Disclosure CVSS 3.1MEDIUM 4.3
  • TI-2022-00987 myCred < 2.4.4 - Subscriber+ Import/Export to Email Address Disclosure CVSS 3.1MEDIUM 4.3
  • TI-2022-00288 myCred < 2.4.4 - Subscriber+ Arbitrary Post Creation CVSS 3.1MEDIUM 4.3

Sources