Affiliate Manager < 2.8.7 - Admin+ SQL injection
Priority LOW 35CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-89.
Summary
The Affiliates Manager WordPress plugin before 2.8.7 does not validate the orderby parameter before using it in an SQL statement in the admin dashboard, leading to an SQL Injection issue
Why it matters now
EPSS 0.01533 74th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Affiliates Manager (Unknown): 2.8.7
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Affiliates Manager | 2.8.7 to before 2.8.7 | 2.8.7 | Patch available | CNA |
- Affiliates Manager VendorUnknown Affected 2.8.7 to before 2.8.7 Fixed in 2.8.7 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wpaffiliatemanager:affiliates_manager:*:*:*:*:*:wordpress:*:* | before 2.8.7 | Vulnerable | wp.insider, wpaffiliatemgr |
- cpe:2.3:a:wpaffiliatemanager:affiliates_manager:*:*:*:*:*:wordpress:*:* Versions before 2.8.7 Vulnerable ·wp.insider, wpaffiliatemgr
Remediation
- Fix · CNA Affiliates Manager (Unknown) Fixed in 2.8.7
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24844
- 2026-10-03 Alias added: GHSA-jcf4-w72w-52p8
References
More wp.insider, wpaffiliatemgr Affiliates Manager vulnerabilities
- TI-2023-28569 WordPress Affiliates Manager Plugin <= 2.9.31 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2019-11928 The affiliates-manager plugin before 2.6.6 for WordPress has CSRF. CVSS 3.0HIGH 8.8
- TI-2023-13448 WordPress Affiliates Manager Plugin <= 2.9.20 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2022-02593 Affiliates Manager < 2.9.14 - Affiliate CSV Injection CVSS 3.1HIGH 8.0
- TI-2021-07356 Affiliates Manager < 2.9.0 - Unauthenticated Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2023-28585 WordPress Affiliates Manager Plugin <= 2.9.30 is vulnerable to Sensitive Data Exposure CVSS 3.1MEDIUM 5.3
Sources
- CVE-2021-24844 · CVE Program
- CVE-2021-24844 · NVD
- FIRST EPSS
- GHSA-jcf4-w72w-52p8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences