Read the docs
TI-2021-07356 Aliases CVE-2021-25078GHSA-fm8r-hhjh-xqg8

Affiliates Manager < 2.9.0 - Unauthenticated Stored Cross-Site Scripting

Priority LOW 32CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The Affiliates Manager WordPress plugin before 2.9.0 does not validate, sanitise and escape the IP address of requests logged by the click tracking feature, allowing unauthenticated attackers to perform Cross-Site Scripting attacks against admin viewing the tracked requests.

Why it matters now

EPSS 0.02288 83rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Affiliates Manager (Unknown): 2.9.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownAffiliates Manager2.9.0 to before 2.9.02.9.0Patch availableCNA
  • Affiliates Manager VendorUnknown Affected 2.9.0 to before 2.9.0 Fixed in 2.9.0 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:wpaffiliatemanager:affiliates_manager:*:*:*:*:*:wordpress:*:*before 2.9.0Vulnerablewp.insider, wpaffiliatemgr
  • cpe:2.3:a:wpaffiliatemanager:affiliates_manager:*:*:*:*:*:wordpress:*:* Versions before 2.9.0 Vulnerable ·wp.insider, wpaffiliatemgr

Remediation

  • Fix · CNA Affiliates Manager (Unknown) Fixed in 2.9.0

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-25078
  2. 2026-10-03 Alias added: GHSA-fm8r-hhjh-xqg8

References

  • TI-2023-28569 WordPress Affiliates Manager Plugin <= 2.9.31 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
  • TI-2019-11928 The affiliates-manager plugin before 2.6.6 for WordPress has CSRF. CVSS 3.0HIGH 8.8
  • TI-2023-13448 WordPress Affiliates Manager Plugin <= 2.9.20 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
  • TI-2022-02593 Affiliates Manager < 2.9.14 - Affiliate CSV Injection CVSS 3.1HIGH 8.0
  • TI-2021-07126 Affiliate Manager < 2.8.7 - Admin+ SQL injection CVSS 3.1HIGH 7.2
  • TI-2023-28585 WordPress Affiliates Manager Plugin <= 2.9.30 is vulnerable to Sensitive Data Exposure CVSS 3.1MEDIUM 5.3
See all 8 →

Sources