eCommerce Product Catalog for WordPress < 3.0.39 - Reflected Cross-Site Scripting
Priority LOW 31CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The eCommerce Product Catalog Plugin for WordPress plugin before 3.0.39 does not escape the ic-settings-search parameter before outputting it back in the page in an attribute, leading to a Reflected Cross-Site Scripting issue
Why it matters now
EPSS 0.01655 76th percentileScored 2026-11-07
Fix Fixed eCommerce Product Catalog Plugin for WordPress (Unknown): 3.0.39
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | eCommerce Product Catalog Plugin for WordPress | 3.0.39 to before 3.0.39 | 3.0.39 | Patch available | CNA |
- eCommerce Product Catalog Plugin for WordPress VendorUnknown Affected 3.0.39 to before 3.0.39 Fixed in 3.0.39 Patch available CNA
Remediation
- Fix · CNA eCommerce Product Catalog Plugin for WordPress (Unknown) Fixed in 3.0.39
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24875
- 2026-10-03 Alias added: GHSA-wg38-4947-72vf
References
More impleCode Ecommerce Product Catalog vulnerabilities
- TI-2023-28334 WordPress eCommerce Product Catalog Plugin <= 3.3.26 is vulnerable to Sensitive Data Exposure CVSS 3.1HIGH 7.5
- TI-2023-25947 WordPress eCommerce Product Catalog Plugin <= 3.3.26 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
- TI-2023-05509 eCommerce Product Catalog Plugin for WordPress < 3.3.26 - Products Deletion via CSRF CVSS 3.1MEDIUM 6.5
- TI-2023-10522 WordPress eCommerce Product Catalog Plugin <= 3.3.4 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9
- TI-2023-01389 eCommerce Product Catalog plugin for WordPress <= 3.3.8 - Authenticated (Administrator+) Stored Cross-Site Scripting CVSS 3.1MEDIUM 4.8
- TI-2021-03250 eCommerce Product Catalog Plugin for WordPress <= 3.0.17 - Cross-Site Request Forgery Bypass CVSS 3.1MEDIUM 4.3
Sources
- CVE-2021-24875 · CVE Program
- CVE-2021-24875 · NVD
- FIRST EPSS
- GHSA-wg38-4947-72vf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences