Read the docs
TI-2021-07165 Aliases CVE-2021-24883GHSA-9fv2-2p6h-wc29

Popup Anything < 2.0.4 - Contributor+ Stored Cross-Site Scripting

Priority LOW 26CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The Popup Anything WordPress plugin before 2.0.4 does not escape the Link Text and Button Text fields of Popup, which could allow users with a role as low as Contributor to perform Cross-Site Scripting attacks

Why it matters now

EPSS 0.00804 56th percentileScored 2026-11-07
Fix Fixed Popup Anything – A Marketing Popup (Unknown): 2.0.4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownPopup Anything – A Marketing Popup2.0.4 to before 2.0.42.0.4Patch availableCNA
  • Popup Anything – A Marketing Popup VendorUnknown Affected 2.0.4 to before 2.0.4 Fixed in 2.0.4 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:essentialplugin:popup_anything:*:*:*:*:*:wordpress:*:*before 2.0.4VulnerableWP OnlineSupport, Essential Plugin

Remediation

  • Fix · CNA Popup Anything – A Marketing Popup (Unknown) Fixed in 2.0.4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-24883
  2. 2026-10-03 Alias added: GHSA-9fv2-2p6h-wc29

References

  • TI-2022-17790 WordPress Popup Anything Plugin <= 2.2.1 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
  • TI-2022-01956 Popup Anything < 2.1.7 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1

Sources