Popup Anything < 2.1.7 - Reflected Cross-Site Scripting
Priority LOW 28CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Popup Anything WordPress plugin before 2.1.7 does not sanitise and escape a parameter before outputting it back in a frontend page, leading to a Reflected Cross-Site Scripting
Why it matters now
EPSS 0.0067 52nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Popup Anything – A Marketing Popup and Lead Generation Conversions (Unknown): 2.1.7
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Popup Anything – A Marketing Popup and Lead Generation Conversions | 2.1.7 to before 2.1.7 | 2.1.7 | Patch available | CNA |
- Popup Anything – A Marketing Popup and Lead Generation Conversions VendorUnknown Affected 2.1.7 to before 2.1.7 Fixed in 2.1.7 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:essentialplugin:popup_anything:*:*:*:*:*:wordpress:*:* | before 2.1.7 | Vulnerable | WP OnlineSupport, Essential Plugin |
- cpe:2.3:a:essentialplugin:popup_anything:*:*:*:*:*:wordpress:*:* Versions before 2.1.7 Vulnerable ·WP OnlineSupport, Essential Plugin
Remediation
- Fix · CNA Popup Anything – A Marketing Popup and Lead Generation Conversions (Unknown) Fixed in 2.1.7
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2115
- 2026-10-03 Alias added: GHSA-mch4-6f94-27mh
- 2026-10-11 EPSS moved to the 50th–90th percentile
References
More WP OnlineSupport, Essential Plugin Popup Anything vulnerabilities
- TI-2022-17790 WordPress Popup Anything Plugin <= 2.2.1 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2021-07165 Popup Anything < 2.0.4 - Contributor+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 5.4
Sources
- CVE-2022-2115 · CVE Program
- CVE-2022-2115 · NVD
- FIRST EPSS
- GHSA-mch4-6f94-27mh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences