Read the docs
TI-2021-07190 Aliases CVE-2021-24910GHSA-vvqg-9xpw-c884

Transposh WordPress Translation < 1.0.8 - Reflected Cross-Site Scripting

Priority LOW 31CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The Transposh WordPress Translation WordPress plugin before 1.0.8 does not sanitise and escape the a parameter via an AJAX action (available to both unauthenticated and authenticated users when the curl library is installed) before outputting it back in the response, leading to a Reflected Cross-Site Scripting issue

Why it matters now

EPSS 0.01672 76th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Transposh WordPress Translation (Unknown): 1.0.8

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownTransposh WordPress Translation1.0.8 to before 1.0.81.0.8Patch availableCNA
  • Transposh WordPress Translation VendorUnknown Affected 1.0.8 to before 1.0.8 Fixed in 1.0.8 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:transposh:transposh_wordpress_translation:*:*:*:*:*:wordpress:*:*before 1.0.8Vulnerableoferwald
  • cpe:2.3:a:transposh:transposh_wordpress_translation:*:*:*:*:*:wordpress:*:* Versions before 1.0.8 Vulnerable ·oferwald

Remediation

  • Fix · CNA Transposh WordPress Translation (Unknown) Fixed in 1.0.8

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    Transposh WordPress Translation 1.0.8

    4 records Highest priority Priority LOW 4 LOW

    Other records, highest priority first

    • TI-2022-09382 Transposh WordPress Translation < 1.0.8 - Admin+ RCEPriority LOW 35
    • TI-2021-07191 Transposh WordPress Translation < 1.0.8 - Stored Cross-Site ScriptingPriority LOW 26
    • TI-2021-07192 Transposh WordPress Translation < 1.0.8 - CSRF to Stored XSSPriority LOW 24

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-24910
  2. 2026-10-03 Alias added: GHSA-vvqg-9xpw-c884

References

  • TI-2022-02272 Transposh WordPress Translation <= 1.0.9.6 - Unauthorized Settings Change CVSS 3.1MEDIUM 5.3
  • TI-2022-02343 Transposh WordPress Translation <= 1.0.9.6 - Authorization Bypass CVSS 3.1HIGH 7.5
  • TI-2022-02273 Transposh WordPress Translation <= 1.0.9.6 - Sensitive Information Disclosure CVSS 3.1MEDIUM 5.3
  • TI-2022-09382 Transposh WordPress Translation < 1.0.8 - Admin+ RCE CVSS 3.1HIGH 7.2
  • TI-2022-09381 Transposh WordPress Translation <= 1.0.8 - Admin+ SQL Injection CVSS 3.1HIGH 7.2
  • TI-2022-09380 Transposh WordPress Translation <= 1.0.8 - Subscriber+ Unauthorised Calls CVSS 3.1MEDIUM 6.5
See all 8 →

Sources