Transposh WordPress Translation < 1.0.8 - Stored Cross-Site Scripting
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Transposh WordPress Translation WordPress plugin before 1.0.8 does not sanitise and escape the tk0 parameter from the tp_translation AJAX action, leading to Stored Cross-Site Scripting, which will trigger in the admin dashboard of the plugin. The minimum role needed to perform such attack depends on the plugin "Who can translate ?" setting.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Transposh WordPress Translation | 1.0.8 to before 1.0.8 | 1.0.8 | Patch available | CNA |
- Transposh WordPress Translation VendorUnknown Affected 1.0.8 to before 1.0.8 Fixed in 1.0.8 Patch available CNA
Remediation
- Fix · CNA Transposh WordPress Translation (Unknown) Fixed in 1.0.8
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Transposh WordPress Translation 1.0.8
4 records Highest priority Priority LOW 4 LOW
Other records, highest priority first
- TI-2022-09382 Transposh WordPress Translation < 1.0.8 - Admin+ RCEPriority LOW 35
- TI-2021-07190 Transposh WordPress Translation < 1.0.8 - Reflected Cross-Site ScriptingPriority LOW 31
- TI-2021-07192 Transposh WordPress Translation < 1.0.8 - CSRF to Stored XSSPriority LOW 24
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24911
- 2026-10-03 Alias added: GHSA-p553-xq2c-fgrg
References
More oferwald Transposh Wordpress Translation vulnerabilities
- TI-2022-02272 Transposh WordPress Translation <= 1.0.9.6 - Unauthorized Settings Change CVSS 3.1MEDIUM 5.3
- TI-2022-02343 Transposh WordPress Translation <= 1.0.9.6 - Authorization Bypass CVSS 3.1HIGH 7.5
- TI-2022-02273 Transposh WordPress Translation <= 1.0.9.6 - Sensitive Information Disclosure CVSS 3.1MEDIUM 5.3
- TI-2022-09382 Transposh WordPress Translation < 1.0.8 - Admin+ RCE CVSS 3.1HIGH 7.2
- TI-2022-09381 Transposh WordPress Translation <= 1.0.8 - Admin+ SQL Injection CVSS 3.1HIGH 7.2
- TI-2022-09380 Transposh WordPress Translation <= 1.0.8 - Subscriber+ Unauthorised Calls CVSS 3.1MEDIUM 6.5
Sources
- CVE-2021-24911 · CVE Program
- CVE-2021-24911 · NVD
- FIRST EPSS
- GHSA-p553-xq2c-fgrg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences