Read the docs
TI-2021-07209 Aliases CVE-2021-24930GHSA-jhv5-5gxp-jg64

Bookly < 20.3.1 - Staff Member Stored Cross-Site Scripting

Priority LOW 25CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The WordPress Online Booking and Scheduling Plugin WordPress plugin before 20.3.1 does not escape the Staff Full Name field before outputting it back in a page, which could lead to a Stored Cross-Site Scripting issue

Why it matters now

EPSS 0.00624 50th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed WordPress Online Booking and Scheduling Plugin – Bookly (Unknown): 20.3.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownWordPress Online Booking and Scheduling Plugin – Bookly20.3.1 to before 20.3.120.3.1Patch availableCNA
  • WordPress Online Booking and Scheduling Plugin – Bookly VendorUnknown Affected 20.3.1 to before 20.3.1 Fixed in 20.3.1 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:booking-wp-plugin:bookly:*:*:*:*:*:wordpress:*:*before 20.3.1VulnerableBooking-wp-plugin
  • cpe:2.3:a:booking-wp-plugin:bookly:*:*:*:*:*:wordpress:*:* Versions before 20.3.1 Vulnerable ·Booking-wp-plugin

Remediation

  • Fix · CNA WordPress Online Booking and Scheduling Plugin – Bookly (Unknown) Fixed in 20.3.1

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-24930
  2. 2026-10-03 Alias added: GHSA-jhv5-5gxp-jg64
  3. 2026-11-04 EPSS moved to the 50th–90th percentile

References

  • TI-2023-04323 Bookly < 22.4 - Admin+ SQLi CVSS 3.1HIGH 7.2
  • TI-2023-01109 The Bookly plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the full… CVSS 3.1HIGH 7.2
  • TI-2018-05034 Bookly #1 WordPress Booking Plugin Lite before 14.5 has XSS via a jQuery.ajax request to ng-payment_details_dialog.js. CVSS 3.1MEDIUM 6.1
  • TI-2023-04793 Bookly < 22.5 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
  • TI-2023-01097 Cross-site scripting in ladela WordPress Online Booking and Scheduling Plugin – Bookly CVSS 3.1MEDIUM 4.8

Sources