Bookly < 22.5 - Admin+ Stored XSS
Priority LOW 22CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The WordPress Online Booking and Scheduling Plugin WordPress plugin before 22.5 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Why it matters now
EPSS 0.00451 39th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed WordPress Online Booking and Scheduling Plugin (Unknown): 22.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WordPress Online Booking and Scheduling Plugin | before 22.5 | 22.5 | Patch available | CNA |
- WordPress Online Booking and Scheduling Plugin VendorUnknown Affected before 22.5 Fixed in 22.5 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:booking-wp-plugin:bookly:*:*:*:*:*:wordpress:*:* | up to 22.5 | Vulnerable | Booking-wp-plugin |
- cpe:2.3:a:booking-wp-plugin:bookly:*:*:*:*:*:wordpress:*:* Versions up to 22.5 Vulnerable ·Booking-wp-plugin
Remediation
- Fix · CNA WordPress Online Booking and Scheduling Plugin (Unknown) Fixed in 22.5
Timeline
- 2026-10-02 Threatist record created from CVE-2023-5209
- 2026-10-03 Alias added: GHSA-hgwf-985j-mh3j
References
More Booking-wp-plugin Bookly vulnerabilities
- TI-2023-04323 Bookly < 22.4 - Admin+ SQLi CVSS 3.1HIGH 7.2
- TI-2023-01109 The Bookly plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the full… CVSS 3.1HIGH 7.2
- TI-2018-05034 Bookly #1 WordPress Booking Plugin Lite before 14.5 has XSS via a jQuery.ajax request to ng-payment_details_dialog.js. CVSS 3.1MEDIUM 6.1
- TI-2021-07209 Bookly < 20.3.1 - Staff Member Stored Cross-Site Scripting CVSS 3.1MEDIUM 5.4
- TI-2023-01097 Cross-site scripting in ladela WordPress Online Booking and Scheduling Plugin – Bookly CVSS 3.1MEDIUM 4.8
Sources
- CVE-2023-5209 · CVE Program
- CVE-2023-5209 · NVD
- FIRST EPSS
- GHSA-hgwf-985j-mh3j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences