Bookly < 22.4 - Admin+ SQLi
Priority HIGH 67Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The WordPress Online Booking and Scheduling Plugin WordPress plugin before 22.4 does not properly sanitise and escape a parameter before using it in a SQL statement, leading to a SQL injection exploitable by high privilege users such as admin
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00902 59th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed WordPress Online Booking and Scheduling Plugin (Unknown): 22.4
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WordPress Online Booking and Scheduling Plugin | before 22.4 | 22.4 | Patch available | CNA |
- WordPress Online Booking and Scheduling Plugin VendorUnknown Affected before 22.4 Fixed in 22.4 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:booking-wp-plugin:bookly:*:*:*:*:*:wordpress:*:* | before 22.4 | Vulnerable | Booking-wp-plugin |
- cpe:2.3:a:booking-wp-plugin:bookly:*:*:*:*:*:wordpress:*:* Versions before 22.4 Vulnerable ·Booking-wp-plugin
Remediation
- Fix · CNA WordPress Online Booking and Scheduling Plugin (Unknown) Fixed in 22.4
Timeline
- 2026-10-02 Threatist record created from CVE-2023-4691
- 2026-10-03 Alias added: GHSA-p3m2-9555-cgrw
References
More Booking-wp-plugin Bookly vulnerabilities
- TI-2023-01109 The Bookly plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the full… CVSS 3.1HIGH 7.2
- TI-2018-05034 Bookly #1 WordPress Booking Plugin Lite before 14.5 has XSS via a jQuery.ajax request to ng-payment_details_dialog.js. CVSS 3.1MEDIUM 6.1
- TI-2021-07209 Bookly < 20.3.1 - Staff Member Stored Cross-Site Scripting CVSS 3.1MEDIUM 5.4
- TI-2023-04793 Bookly < 22.5 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2023-01097 Cross-site scripting in ladela WordPress Online Booking and Scheduling Plugin – Bookly CVSS 3.1MEDIUM 4.8
Sources
- CVE-2023-4691 · CVE Program
- CVE-2023-4691 · NVD
- FIRST EPSS
- GHSA-p3m2-9555-cgrw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences