PPOM for WooCommerce < 24.0 - Subscriber+ Settings Update to Stored XSS
Priority LOW 25CWE-862Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-862.
Summary
The PPOM for WooCommerce WordPress plugin before 24.0 does not have authorisation and CSRF checks in the ppom_settings_panel_action AJAX action, allowing any authenticated to call it and set arbitrary settings. Furthermore, due to the lack of sanitisation and escaping, it could lead to Stored XSS issues
Why it matters now
EPSS 0.00524 44th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed PPOM for WooCommerce (Unknown): 24.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | PPOM for WooCommerce | 24.0 to before 24.0 | 24.0 | Patch available | CNA |
- PPOM for WooCommerce VendorUnknown Affected 24.0 to before 24.0 Fixed in 24.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:najeebmedia:ppom_for_woocommerce:*:*:*:*:*:wordpress:*:* | before 24.0 | Vulnerable | Najeebmedia |
- cpe:2.3:a:najeebmedia:ppom_for_woocommerce:*:*:*:*:*:wordpress:*:* Versions before 24.0 Vulnerable ·Najeebmedia
Remediation
- Fix · CNA PPOM for WooCommerce (Unknown) Fixed in 24.0
Timeline
- 2026-10-02 Threatist record created from CVE-2021-25018
- 2026-10-03 Alias added: GHSA-gvfj-h2wq-cw77
References
More Najeebmedia Ppom For Woocommerce vulnerabilities
- TI-2019-11146 The woocommerce-product-addon plugin before 18.4 for WordPress has XSS via an import of a new meta data structure. CVSS 3.1MEDIUM 5.4
Sources
- CVE-2021-25018 · CVE Program
- CVE-2021-25018 · NVD
- FIRST EPSS
- GHSA-gvfj-h2wq-cw77 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences