SEO Plugin by Squirrly SEO < 11.1.12 - Reflected Cross-Site Scripting
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The SEO Plugin by Squirrly SEO WordPress plugin before 11.1.12 does not escape the type parameter before outputting it back in an attribute in an admin page, leading to a Reflected Cross-Site Scripting
Why it matters now
EPSS 0.008 56th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed SEO Plugin by Squirrly SEO (Unknown): 11.1.12
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | SEO Plugin by Squirrly SEO | 11.1.12 to before 11.1.12 | 11.1.12 | Patch available | CNA |
- SEO Plugin by Squirrly SEO VendorUnknown Affected 11.1.12 to before 11.1.12 Fixed in 11.1.12 Patch available CNA
Remediation
- Fix · CNA SEO Plugin by Squirrly SEO (Unknown) Fixed in 11.1.12
Timeline
- 2026-10-02 Threatist record created from CVE-2021-25019
- 2026-10-03 Alias added: GHSA-7xm8-fw8m-2w46
References
More cifi Seo Plugin By Squirrly Seo vulnerabilities
- TI-2024-06026 SEO Plugin by Squirrly SEO <= 12.3.19 - Authenticated (Contributor+) SQL Injection via url Parameter CVSS 3.1HIGH 8.8
- TI-2024-09739 SEO Plugin by Squirrly SEO < 12.3.21 - Editor+ Stored XSS CVSS 3.1LOW 3.5
- TI-2025-16664 WordPress SEO Plugin by Squirrly SEO plugin <= 12.4.03 - SQL Injection vulnerability CVSS 3.1HIGH 8.8
- TI-2024-28938 WordPress Squirrly SEO plugin <= 12.3.19 - SQL Injection vulnerability CVSS 3.1HIGH 8.8
- TI-2022-17844 WordPress SEO Plugin by Squirrly SEO Plugin <= 12.1.10 is vulnerable to Arbitrary File Upload CVSS 3.1HIGH 8.8
- TI-2025-18371 WordPress Squirrly SEO plugin <= 12.4.07 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
Sources
- CVE-2021-25019 · CVE Program
- CVE-2021-25019 · NVD
- FIRST EPSS
- GHSA-7xm8-fw8m-2w46 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences