SEO Plugin by Squirrly SEO < 12.3.21 - Editor+ Stored XSS
Priority MEDIUM 50CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
In the process of testing the SEO Plugin by Squirrly SEO WordPress plugin before 12.3.21, a vulnerability was found that allows you to implement Stored XSS on behalf of the editor by embedding malicious script, which entails account takeover backdoor
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0033 26th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed SEO Plugin by Squirrly SEO (Unknown): 12.3.21
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | SEO Plugin by Squirrly SEO | before 12.3.21 | 12.3.21 | Patch available | CNA |
- SEO Plugin by Squirrly SEO VendorUnknown Affected before 12.3.21 Fixed in 12.3.21 Patch available CNA
Remediation
- Fix · CNA SEO Plugin by Squirrly SEO (Unknown) Fixed in 12.3.21
Timeline
- 2026-10-02 Threatist record created from CVE-2024-10515
- 2026-10-03 Alias added: GHSA-rf7m-w6xx-cv97
References
More cifi Seo Plugin By Squirrly Seo vulnerabilities
- TI-2024-06026 SEO Plugin by Squirrly SEO <= 12.3.19 - Authenticated (Contributor+) SQL Injection via url Parameter CVSS 3.1HIGH 8.8
- TI-2025-16664 WordPress SEO Plugin by Squirrly SEO plugin <= 12.4.03 - SQL Injection vulnerability CVSS 3.1HIGH 8.8
- TI-2024-28938 WordPress Squirrly SEO plugin <= 12.3.19 - SQL Injection vulnerability CVSS 3.1HIGH 8.8
- TI-2022-17844 WordPress SEO Plugin by Squirrly SEO Plugin <= 12.1.10 is vulnerable to Arbitrary File Upload CVSS 3.1HIGH 8.8
- TI-2025-18371 WordPress Squirrly SEO plugin <= 12.4.07 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
- TI-2023-27759 WordPress Squirrly SEO - Advanced Pack Plugin <= 2.3.8 is vulnerable to SQL Injection CVSS 3.1HIGH 7.6
Sources
- CVE-2024-10515 · CVE Program
- CVE-2024-10515 · NVD
- FIRST EPSS
- GHSA-rf7m-w6xx-cv97 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences