Read the docs
TI-2021-07304 Aliases CVE-2021-25026GHSA-84ph-h2vc-8hrg

Patreon WordPress < 1.8.2 - Admin+ Stored Cross-Site Scripting

Priority LOW 26CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The Patreon WordPress plugin before 1.8.2 does not sanitise and escape the field "Custom Patreon Page name", which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed

Why it matters now

EPSS 0.00699 53rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Patreon WordPress (Unknown): 1.8.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownPatreon WordPress1.8.2 to before 1.8.21.8.2Patch availableCNA
  • Patreon WordPress VendorUnknown Affected 1.8.2 to before 1.8.2 Fixed in 1.8.2 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:patreon:patreon_wordpress:*:*:*:*:*:wordpress:*:*before 1.8.2VulnerablePatreon
  • cpe:2.3:a:patreon:patreon_wordpress:*:*:*:*:*:wordpress:*:* Versions before 1.8.2 Vulnerable ·Patreon

Remediation

  • Fix · CNA Patreon WordPress (Unknown) Fixed in 1.8.2

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-25026
  2. 2026-10-03 Alias added: GHSA-84ph-h2vc-8hrg

References

  • TI-2018-14946 The patreon-connect plugin before 1.2.2 for WordPress has Object Injection. CVSS 3.0CRITICAL 9.8
  • TI-2021-06521 Patreon WordPress < 1.7.2 - Reflected XSS on patreon_save_attachment_patreon_level AJAX action CVSS 3.1CRITICAL 9.6
  • TI-2021-06520 Patreon WordPress < 1.7.2 - Reflected XSS on Login Form CVSS 3.1CRITICAL 9.6
  • TI-2021-06519 Patreon WordPress < 1.7.0 - Unauthenticated Local File Disclosure CVSS 3.1HIGH 7.5
  • TI-2023-21745 WordPress Patreon WordPress Plugin <= 1.8.6 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
  • TI-2021-06522 Patreon WordPress < 1.7.0 - CSRF to Overwrite/Create User Meta CVSS 3.1HIGH 8.1
See all 7 →

Sources